Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Recently, I've been having problems with my late 2009 MacBook Pro crashing several times a day. How can I fix it?

I'm running OS 10.7.3 with 8 GB of RAM.

share|improve this question
    
13-inch or 15-inch? –  binarybob Apr 1 '12 at 17:20
    
15 inches diagonally. –  timothymh Apr 1 '12 at 17:23
1  
Possible duplicate: apple.stackexchange.com/questions/29426/… –  Daniel Lawson Apr 1 '12 at 17:56
    
Which diagonal? If they're not both 15" your screen may be a parallelogram –  Kyle Cronin Apr 1 '12 at 18:11
    
@KyleCronin Hadn't thought about that! I just checked and the top-left-to-bottom-right diagonal is exactly 17" but the bottom-left-to-top-right diagonal is 16.996"! (Apparently I was wrong about the 15 inches.) I have been cheated of—(hang on, let me do the math) –  timothymh Apr 1 '12 at 22:35
show 1 more comment

closed as too localized by Daniel Lawson Apr 2 '12 at 2:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 1 down vote accepted

This is a setting that Apple has for some reason decided to hide completely, and can easily be fixed with a few simple steps.

  1. First, go to /System/Library/CoreServices/ and right-click on Finder. Select Show Package Contents, navigate to …/Contents/Info.plist and open it in TextEdit.

  2. Near the bottom, below the last </array> but before the last </dict>, add the following two lines of code: <key>ShowCrashPrefs</key> <true/>

  3. Save and quit TextEdit. Hold ctrl+opt while clicking on the Finder icon and select Relaunch. Once Finder fully loads again, advance to step 4.

  4. Open Finder preferences with Finder > Preferences… or +, and navigate to the Advanced tab. Tick the "Show crash prefpane in System Preferences" option. Finder Prefs

  5. Launch System preferences and select the new Crash icon, under System. When it loads, drag the crash frequency slider to Min.

System Prefs

share|improve this answer
5  
Here’s a one-liner that you can use in Terminal.app instead of step 1 and 2: defaults write NSGlobalDomain ShowCrashPrefs -bool true. It should be noted that on pre-Lion OS X versions, the “Max” label says “Windows mode” instead. –  Mathias Bynens Apr 1 '12 at 16:50
    
@MathiasBynens Good catch! –  timothymh Apr 1 '12 at 16:52
    
What happens if Crash frequency is set for a negative value? –  Daniel Lawson Apr 2 '12 at 2:44
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.