Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have been trying to restore my iPhone 4S over iCloud since yesterday. Invariably, it will fail with the message that the iPhone is no longer connected to the internet.

The wifi over which my iPhone is connected is also being used by four other computers that have no problems maintaining their connection with the internet.

Currently, the estimated time remaining for the restore is 11 hours. It has come down from 52 hours. This over a broadband connection of 120Mb/sec down and 9 Mb/sec up.

The size of the backup on iCloud from which I am trying to restore my iPhone is 8GB.

Please advise.

Edit - to clarify: the problem is that iCloud restore fails. Also, I tried turning off my Airport Extreme router for about five minutes earlier today. No luck: restore from iCloud failed after an hour and a half with the message that the iPhone was not connected to the internet. I also tried to connect the ADSL modem directly to my MacBook Air, sharing its internet connection over wifi my my iPhone 4S with the exact same result.

Edit 2 - I can start the restore, but it finishes after an hour or so with the dialog box that the iPhone is not connected to the internet.

share|improve this question

migrated from superuser.com Mar 31 '12 at 12:39

This question came from our site for computer enthusiasts and power users.

    
what is the problem? that it fails or that it takes too long? –  Walter Maier-Murdnelch Mar 31 '12 at 12:07
    
Hi Walter. Thanks for asking for clarification. The problem is, iCloud restore fails. –  mbotta Mar 31 '12 at 12:34
    
So, you can start the restart, but can't finish it? –  Michiel Mar 31 '12 at 14:03
    
I can start the restore, but it finishes after an hour or so with the dialog box that the iPhone is not connected to the internet. –  mbotta Mar 31 '12 at 15:15
1  
@Robert - nope. In the end, I just reinstalled everything and lost all app data in the process :/ –  mbotta May 13 '12 at 18:11
show 2 more comments

3 Answers 3

I had the same problem. Tried for days to get it to work. On my 17th try, the restore completed. On that try, I was keeping the display active by tapping it every 40 seconds for around 2 hours and I had also turned off all encryption on my router. Not sure what caused it to work this time.

The weird thing is, the restore finished when the status bar said there were "about 3 hours" left in the restore. Seems like it miscalculated the size of my backup or something like that.

Apple really needs to figure this out.

share|improve this answer
add comment

I found that it fails unless the screen is on when it gets to 100%. Which is hard to ensure since the screen turns off after one minute when restoring from a backup :P

share|improve this answer
add comment

It seems if you only leave it for a few minutes it either keeps downloading, or pauses but is able to resume. If you leave it for longer it seems like power saving kicks in and the WiFi gets turned off...

I've spoken to several people on the phone at Apple, they are helpful but their only suggestion is tapping the screen to keep it awake. One guy got my hopes up saying if you turn 'Back to your Mac' on it will download the iCloud backups and let you restore, but when I pushed him on that, turns out it actually doesn't. Just lets you see them and buy more storage... (as well as the other Back to my Mac stuff).

share|improve this answer
add comment

protected by Community Aug 23 '12 at 20:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.