Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have this very strange issue with my iPhone 4's (iOS 5.0.1 9A405) Contacts app.

As you know, there is this "bar" on the right which allows you to touch a letter and have the table directly "jump" to that letter:

enter image description here

On my iPhone, the bar only works for letters A, B, C, and Z. Not the letters in between. If I touch any of the letters D-Y, it jumps to C. Huh? Note that searching for a contact starting with letters D-Y and/or scrolling to it manually works fine.

While investigating for the possible cause of this weird behavior, I also found out that there's a section # between the letters C and D, which I suspect might be causing the problem. Why is it there? All contacts in that section start with C and should thus be in the C section. Here are two screenshots of the misplaced # section:

enter image description here

enter image description here

Thanks a lot for your help!

share|improve this question
    
Have you tried upgrading to iOS 5.1 to see if the problem persists? –  user479 Mar 31 '12 at 5:18
    
@RandolphWest: no, because my iPhone is jailbroken and thus I need to stay on 5.0.1 (there is no untethered jailbreak for iOS 5.1 yet). –  houbysoft Mar 31 '12 at 15:37
    
I would suggest that running on an older, and unsupported, OS, is going to make answering your question difficult, especially if this is a known problem that has been repaired in iOS 5.1 (I don't know whether or not this is true, but it's a possibility). –  user479 Mar 31 '12 at 22:54
    
@RandolphWest: I do realize that ideally I would update. However, I know many people for whom this works just fine, and they are also on iOS 5.0.1, so I don't think this is a known issue. –  houbysoft Apr 1 '12 at 3:45
    
@RandolphWest: I'm now on 5.1.1 (latest), and the issue is still there... I've tried doing a full restore too, but it didn't help either. –  houbysoft Jun 15 '12 at 14:37
show 2 more comments

1 Answer 1

up vote 1 down vote accepted

I finally fixed this by removing/renaming all the contacts in the misplaced '#' section.

No idea why it happened in the first place...

share|improve this answer
    
Interesting find. I've voted this up. –  user479 Jun 18 '12 at 17:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.