Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I start up my MacBook Air, it makes a loud startup sound unless I muted the computer prior to shutting down last time.

However, I cannot guarantee that I had muted the computer last time before shut down because I share this Air with others.

How do I start up my Mac silently?

share|improve this question
2  
Just curious, but why do you shutdown? My MBP has never been shutdown for reasons other than upgrading hardware (memory) –  EmmEff Mar 30 '12 at 20:55
3  
Reopening - this is about an Air and covers new ground. Merging answers is bad for the site in general and it's OK to have a handful of close questions - this one is clearly not an exact duplicate of the other. See how both answers here are different than the other question's answers. –  bmike Mar 31 '12 at 5:43
add comment

4 Answers 4

up vote 18 down vote accepted

Plugging in headphones used to be the quick and dirty way to assure silence (back in the PPC hardware days).

Now, the self test startup chime still uses the internal speaker whether or not the headphone jack is in use, but the below trick will work on older macs. It is of use with new macs as long as you don't set your mac to reboot automatically and you don't forget about the current behavior and reboot it yourself.

I have a snipped nub of a headphone jack that I use when I am in a place where noise is prohibited no matter what the software decides.

You can get a plug without any cord for less than $5 at a store such as Radio Shack if you don't have headphones you can sacrifice or the cut cord doesn't please you.

It's simply not possible to change the NVRAM mute/volume setting after the mac is shut down (or sleeping) so even if you prepare properly, sound will be made if things don't go as planned on the shutdown.

share|improve this answer
3  
Will this trick work with Intel Macs? My understanding is that it only works with PowerPC Macs and earlier. I know my Mac Pros, MacBook Pros, and Mac mini always use the internal speakers, even with something plugged into the headphone port. –  joelseph Mar 30 '12 at 18:19
    
@joelseph My mini and macbrook pro turn off the internal speakers when I plug a headset in. I'd be interested if you could give us the model numbers and try it out if you still have them just in case. I suspect they can be configured that way, but with a clean OS they should divert sound to the headset. –  Adam Davis Mar 30 '12 at 18:59
    
@AdamDavis This does not work on my Macbook Pro early 2011 and my Macbook Pro mid 2007. –  gentmatt Mar 30 '12 at 19:47
3  
I should clarify that it's only the startup chime that always uses the internal speakers, regardless of whether the Mac's audio output is set to internal speakers, headphones or even digital. I've observed this with all Mac Pro models, 5-6 different MacBook Pros, two Mac minis and an iMac. I just verified the behavior on a MacBook Pro (17-inch Early 2008), MBP (17-inch Mid 2011), and a Mac mini (Early 2009). –  joelseph Mar 30 '12 at 19:48
    
@joelseph Ah, I see, that makes sense. It's apple's trademark sound, and they want it heard... –  Adam Davis Mar 31 '12 at 0:28
add comment

For Snow Leopard and earlier machines download and install "StartupSound.prefPane" which will install a preference pane in system settings to allow you to adjust the startup volume and disable the startup sound:

http://www5e.biglobe.ne.jp/~arcana/StartupSound/BETA/index.en.html

Note that the above has mixed results in Lion. For Lion users the following is recommended:

  1. Login as administrator and open a terminal window

  2. Create scriptfile for muting

    sudo nano /path/to/mute-on.sh

  3. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash
    osascript -e 'set volume with output muted'

  4. Create scriptfile for unmuting

    sudo nano /path/to/mute-off.sh

  5. Enter this as content, when done press control+O to save and control+X to exit:

    #!/bin/bash
    osascript -e 'set volume without output muted'

  6. Make both files executable:

    sudo chmod u+x /path/to/mute-on.sh
    sudo chmod u+x /path/to/mute-off.sh

  7. Check if any hooks already exist (these will be overwritten, so make sure it is OK for you)

    sudo defaults read com.apple.loginwindow LoginHook
    sudo defaults read com.apple.loginwindow LogoutHook

  8. Add hooks for muting

    sudo defaults write com.apple.loginwindow LogoutHook /path/to/mute-on.sh
    sudo defaults write com.apple.loginwindow LoginHook /path/to/mute-off.sh

Notes:

  • /path/to/ is the location of the scripts, I used /Library/Scripts/
  • you can skip the unmuting loginhook (i.e. each logout will silence your machine), but I like it this way because I always have sound available exactly at the volume level I set last time
  • root has to be the owner of the script files - running an editor from command line with sudo is the easiest way to achieve that (otherwise you need to chown)
  • to delete the hooks, use the following:

    sudo defaults delete com.apple.loginwindow LoginHook
    sudo defaults delete com.apple.loginwindow LogoutHook

(source)

share|improve this answer
2  
The logout hook won't run if the mac crashes, NVRAM gets reset or fails to work. It also doesn't help if the mac is simply put asleep with sound playing. It's the best you can do with software, but silent headphones handle all situations where you don't want noise. –  bmike Mar 30 '12 at 17:17
    
Except that new macs (or maybe lion?) still play the startup sound even if headphones are in. –  TJ Luoma Apr 3 '12 at 20:30
    
^ Thank you! Works perfectly - tested on latest Macbook Pro Retina (november 2012) on MacOS X Lion 10.8.2 –  Artur Bodera Nov 18 '12 at 13:28
add comment

This is the only thing that worked for me under OS X 10.8.5 (Mountain Lion) on a 2012-era Mac Mini (Core i5 Intel CPU). In Terminal.app, enter the following command:

sudo nvram SystemAudioVolume=%80

The sudo command will ask for your login password. It needs elevated privileges to update your Mac's NVRAM settings (the Mac equivalent of a PC's BIOS). Don't be put off by the %80 value. It will indeed mute the start-up chime.

If you ever decide you want the chime back again, delete the setting from NVRAM with this command:

sudo nvram -d SystemAudioVolume
share|improve this answer
add comment

My suggestion would be a variation on Adam's answer that sets the volume very low, but not silent. Don't forget that that sound is a cue that the Mac is booting properly. Perhaps someone can post the volume-setting command?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.