Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

We have a MacOS X Lion server with a 140TB external RAID array mounted via a Fibre Channel interface. Whenever anybody logs in, it appears that they own all of the files. How do we set it up so that the partition is mounted by the system on boot and ownership doesn't change to whomever is logged in? We also see this strange behavior when people "ssh" into the server:

08:58 jjj:/corp$ ls -l
total 15104
drwxr-xr-x+ 3 candy7  candy7       102 Mar 12 21:52 junky/
drwxrwxr-x+ 9 candy7  candy7       306 Mar 12 15:43 mist/
08:58 jjj:/corp$ sudo bash
root@jjj:/Volumes/Active01/corp# ls -l
total 15232
drwxr-xr-x+ 3 _unknown  _unknown       102 Mar 12 21:52 junky/
drwxrwxr-x+ 9 _unknown  _unknown       306 Mar 12 15:43 mist/
root@jjj:/Volumes/Active01/corp# su alex
alex@jjj:/Volumes/Active01/corp$ ls -l
total 15104
drwxr-xr-x+ 3 alex  staff       102 Mar 12 21:52 junky
drwxrwxr-x+ 9 alex  staff       306 Mar 12 15:43 mist
alex@jjj:/Volumes/Active01/corp$ 

I think that this has something to do with the 'no owner' mount flag, but I'm not sure.

The thing that has me confused is that we have another system where this isn't a problem, but it's running XServe RAID and this is a RAID from another vendor.

share|improve this question

1 Answer 1

Select the disk in the finder and go to File > Get Info. At the bottom of the panel, in Ownership and Permissions, is "ignore ownership on this volume" checked? If so, uncheck it.

share|improve this answer
    
@WheatWilliams, can you please provide an answer regarding how I would have the external volume managed by Mac OS X Server? That's what I want to do. Thanks! –  vy32 Mar 30 '12 at 16:07
    
@Wheat Williams: I just tested this, and turning off the "Ignore" option appears to apply to all users (and requires admin rights to change), so it should solve vy32's problem. BTW, you can do the same thing from the command line with sudo vsdbutil -a /Volumes/Active01 –  Gordon Davisson Mar 30 '12 at 17:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.