Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been happy with my jailbroken iPod touch and didn't want to upgrade beyond 1.1.4. However, since late last year, perhaps September, the YouTube application hasn't worked, giving the uninformative error "Cannot connect to YouTube". Likewise I cannot reach Google using SSL, only straight HTTP. The error with https://google.com/ first successfully redirects to https://www.google.com/m, but then gives this error:

"Error 502 (Server Error)!!1"

(sic) with the colored Google logo and

"502. That's an error. The server encountered a temporary error and could not complete your request. Please try again in 30 seconds. That's all we know".

But it is not temporary, and I believe the two problems are related. I've edited the Cookies.plist file and cut out the google.com and youtube.com cookies, no help. I'm wondering if it has something to do with root certs, but don't know the plist for those. Any ideas?

share|improve this question
1  
Your old software is old. I think it's time to upgrade. –  user479 Mar 31 '12 at 5:25
    
Maybe your question would have more luck on superuser.com –  Coyote Apr 3 '12 at 0:18
    
@Coyote I think SuperUser would send it straight back to us. It belongs here, horrifically outdated software or not. –  Andrew Larsson Apr 3 '12 at 2:29

1 Answer 1

up vote 3 down vote accepted
+50

Actually I suspect your problem started when the YouTube API 1.0 was dropped by google.

Google notified developers that the YouTube API was deprecated in 2008. Since they keep deprecated APIs running for 3 years, 2011 would be the time they turned the switch on it. It would make sense if all apps and webpages relying on the YouTube API v1.0 failed when they shut it down. They had a lot of problems with YouTube in september 2011 (example with 502 errors). So it's reasonable to say that your iPod will never be able to connect to YouTube if you keep using the early 2008 iPhone OS 1.1.4.

Google released the YouTube Data API (v2.0) around march 2008, after the iOS 1.1.4 was released.

I fear the only solution to get your 1.1.4 device to play YouTube properly would be to get Google to turn the old API back on... Or simply update your iPod :(

share|improve this answer
    
thanks, but I'm much more interested in being able to use Google securely than accessing youtube. apologies that I didn't make that clear enough. –  jcomeau_ictx Apr 3 '12 at 3:45
    
nevertheless, you earned the points. thanks. –  jcomeau_ictx Apr 3 '12 at 4:15
    
update: the SSL access to google.com was restored a few days ago, though YouTube still fails. –  jcomeau_ictx Sep 28 '12 at 6:55
1  
@jcomeau_ictx I fear the API has definitively changed regardless of the SSL access. –  Coyote Oct 8 '12 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.