Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Every few days my iPhone (4) and/or iPad (3rd generation) lose their ability to "see" my iMac and/or Apple TV on the network. This means:

  • The Remote app shows zero sources available for Home Sharing (normally will show both the iMac and the Apple TV)
  • AirPlay cannot be used to send audio or video to the Apple TV
  • Wi-Fi sync will not work (states that it will resume when iMac is available)

Power cycling my router (a Linksys E2000) fixes the problem temporarily, but it always comes back.

Thanks for your help.

share|improve this question
add comment

3 Answers 3

Sounds like a router problem. Bonjour/Zeroconf uses multicast to reach all hosts on the network - if the router treats these incorrectly you have the problem.

If the rest of the network works correctly, then the simplest thing might simply be to replace the master router of your network with an Apple router (they tend to work well with Apple units) and set the current router to be just the internet uplink.

share|improve this answer
    
I assume Linksys do not have a new firmware (and you do not have the option for OpenWRT or similar) –  Thorbjørn Ravn Andersen Jul 15 '12 at 16:20
add comment

I have had similar issues with an iPod touch and having it reliably connect to other (non Apple) home networking equipment.

There are too many variables in your set up described above to diagnose an exact problem. But the types of things you want to try are:

1- Further problem isolation.

You have found that rebooting the router fixes the problem. But what about rebooting just the iPhone? Or rebooting the computer? How about if you just turn the WiFi on the iPhone off then on? Do the iPhone and the iPad leave the house during this time and connect to other networks? What happens if you leave the device in the house for a few days?

2- Depending on the outcomes of the testing above

You might want to try using fixed IP addresses for some or all of your networking components. You do this on the iPhone in Settings->WiFi->YourNetwork->Static. If you are not familiar with this sort of stuff note down the settings on the DHCP tab and copy them into the Static tab. You can always change back to DHCP if things get messed up. I use fixed IP addresses on my iPod touch to mostly solve my problem. See here: http://www.net.princeton.edu/apple-ios/ios41-allows-lease-to-expire-keeps-using-IP-address.html for highly detailed information about a DHCP bug in iOS.

share|improve this answer
add comment

Enabling IGMP snooping in my Asus RT-56U router seems to have fixed this problem. I followed this blogpost:

http://bendera.blogspot.nl/2013/07/asus-rt-n56u-settings-for-airplay.html

Enabling multicast in your router might solve the issue as well. This is what Airplay devices use to detect each other, apparently.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.