Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got Homebrew installed, but:

>brew install iftop
==> Downloading http://www.ex-parrot.com/~pdw/iftop/download/iftop-0.17.tar.gz
File already downloaded in /Volumes/0/z/Library/Caches/Homebrew
==> ./configure --disable-debug --prefix=/usr/local/Cellar/iftop/0.17 --mandir=/usr/local/Cellar/iftop/0.17/share/man
==> make install
ln: iftop: Permission denied
Error: The linking step did not complete successfully
The formula built, but is not symlinked into /usr/local
You can try again using `brew link iftop'
Warning: /usr/local/sbin is not in your PATH
You can amend this by altering your ~/.bashrc file
==> Summary
/usr/local/Cellar/iftop/0.17: 7 files, 116K, built in 3 seconds

FYI, ~/.bashrc does not exist, and

>$PATH
-bash: /Volumes/0/z/android:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/X11/bin: No such file or directory

What should I do? Thanks!

share|improve this question
    
I fixed this by chowning all the folders in /usr/local –  Ze'ev Mar 29 '12 at 1:06
2  
Does brew doctor give back any problems? Also the fact you have permission issues is worth looking in to. –  Allendar Apr 10 '13 at 23:54
    
That package isn't failing for several people here. Have you isolated what is different on your setup? Is this still a problem that you haven't solved? –  bmike Jan 6 at 21:08

2 Answers 2

You can remedy things in your current shell by doing:

mkdir -p /usr/local/sbin
export PATH=${PATH}:/usr/local/sbin
brew link iftop

That'll get you past the warnings and let Homebrew install the iftop package. If the iftop package is installing things in to /usr/local/sbin that you're looking to run, you'll need to ensure this is on your $PATH when you open a shell. To do this, edit ~/.bash_profile and add the line:

export PATH=${PATH}:/usr/local/sbin

To the end of the file to prepend /usr/local/sbin to each new shell you open.

share|improve this answer
    
I got it running by fixing permissions ... but is there any way to run iftop without sudo? Without sudo I get: Permission denied (I want to use this with GeekTool) Thanks! –  Ze'ev Mar 29 '12 at 1:12
1  
Nope. Binding to a network interface is a privileged action. Only super users can do that. –  Ian C. Mar 29 '12 at 1:15
    
Ah ... so no way to make it a Geeklet? –  Ze'ev Mar 29 '12 at 1:29
    
Well... You could make your own script that gets run by a root cronjob, and puts the relevant data into a text file every minute. Then you could get geektool to read the file every minute... To create a root crontab, you just run sudo crontab -e. Everything you put in there will run with root permissions. –  daviewales May 18 '13 at 14:05
    
iftop doesn't seem like the kind of program that could be run in geektool anyway. It needs to output static text, but it appears to run dynamically in curses. –  daviewales May 18 '13 at 14:09

Have you tried using:

$ brew link iftop

As the message recommended? Otherwise it's likely you need to be su to successfully create the symlink. Try:

$ ./configure --disable-debug --prefix=/usr/local/Cellar/iftop/0.17 --mandir=/usr/local/Cellar/iftop/0.17/share/man
$ sudo make install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.