Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a recent MacBook Pro that was running OS X 10.6 but was recently updated to 10.7. My work email switched from Gmail to Exchange and they said to use the built-in Mail app. Overall, I like it, but I can't figure out how to see my drafts folder. According to the help, it only shows up if I have something in it, but I tried composing a message and saving it, and I still don't see my drafts folder in my list of folders. What am I supposed to do about this?

share|improve this question
    
Which version of Exchange, it's pretty important to know the version and how the Exchange account is set up in Mail. –  Stu Wilson Mar 28 '12 at 20:29

3 Answers 3

I fixed this issue by restarting Mail. I have no idea why the drafts folder wasn't showing up before.

share|improve this answer
2  
Then you should accept your own answer. Sometimes a restart help :-) –  Ermiar Mar 28 '12 at 21:15
    
Yes. Please accept your answer by clicking the green checkmark next to your answer. –  daviesgeek Mar 29 '12 at 16:32

This is a setting in Mail preferences. Go to Preferences > Accounts > (account) > Mailbox Behaviors and enable Drafts. preferences

If that doesn't work, show the Favorites Bar (View > Show Favorites Bar) and Drafts should be an option. Click it. favorites bar

share|improve this answer

I just tried it with an Exchange account in Mail app with Mac OS 10.7.3. I got this when I save the message :

Saving message Then I find it in the Draft folder (which were not here before) :

Draft folder appears

Did you try to quit Mail after you saved your message then reopen again ? Check that you have this option enabled in your account preferences too :

enter image description here

Otherwise it could be an Exchange issue.

Hope this helps !

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.