Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Browsing the "network neighborhood" in OS X Finder does show XP machines, but not Windows 7 machines. (Vista machines have a similar problem). I can connect manually to Windows 7 machines ("connect to server" and then specifying "smb://ip_or_name"), but want to be able to browse Win 7 machines automatically.

Browsing works if security is lowered on the Windows 7 machines, and the OS X machine is forced to be the master browser. Question: Who has a better solution? I would like to find another solution without having to change OS X and all Windows 7 machines. Maybe you know some extra OS X software that "makes samba just work right"?

share|improve this question
1  
I find it strange, but… why do my Windows 7 machines are perfectly browsable from OS X (and vice versa) ? I have three folders in my Mac that I share via AFS and Samba and I’ve never had the need to edit the smb.conf file by hand. We don’t have (nor need) a Domain Master… care to share some more information about your setup? Windows Versions? (home? pro?) –  Martín Marconcini Dec 5 '10 at 2:04
    
Well, no idea. It is Windows 7 Enterprise and OS X 10.6.5 . All systems updated with the latest updates at the time of writing. Installed the developer preview of OS X 10.6.6 with the same result. –  Christian Tismer Dec 6 '10 at 18:03
    
Well, no idea. It is Windows 7 Enterprise and OS X 10.6.5 . All systems updated with the latest updates at the time of writing. Installed the developer preview of OS X 10.6.6 with the same result. But I have no OS X Server to test, yet. Maybe that makes the difference? Also, it seems to depend on boot order as I read somewhere. (sorry I edited too slowly) –  Christian Tismer Dec 6 '10 at 18:09
    
Additional note: Windows 7 is installed on a Bootcamp partition. But this should not matter at all. (Did not try Parallels with Win7, yet). About the "no domain master": I think this is not an option. One will always be elected. I just forced OS X to win :-) –  Christian Tismer Dec 6 '10 at 18:15
    
Lion has some improvements to Windows networking. It seems to "just work" –  Paul Eccles Aug 4 '11 at 6:48
add comment

2 Answers

Windows 7 has extra network security options, and one of them sets its discoverability. By default in Windows 7, when you connect to a new network you are prompted for what type of network it should be: Public, Work, or Home. These profiles set up the firewall and security options when on that network; I can't off the top of my head list all the things they specifically set up, but when you select Public, sharing and discoverability are locked tight, whereas in Home they are more relaxed.

It's very likely that you have set your network type to Public on your Windows 7 computer. If you open the Network and Sharing Center, under the name of your active network it should say either "Home network", "Work network" or "Public network". If it is indeed set to Public (or Work), click it and then click Home network. You shouldn't have any problems after that.

Alternatively, you can open the start menu and type Network and hit enter. This opens the Network window, which lets you browse other computers on your network. As soon as the window opens, a yellow bar should appear at the top informing you that network discoverability is turned off; click the bar and then click one of the resolution options. This may fix the problem as well.

I haven't had any problem in OS X connecting to my Windows 7 computers that are set to Home network, as they should be. But a Windows 7 computer set to Public network should be basically undetectable.

share|improve this answer
    
Whow! I was not aware of such a reverse effect, which is not ok still (my machines should see any user of their own shares), but clearly explains it. I will check that today if I can confirm. Could be something to discuss with Apple! –  Christian Tismer Dec 9 '10 at 11:16
    
I don't fully understand your comment, but I am guessing your PCs are desktops. This is not a "reverse effect" in the case of a laptop! It's very handy when you travel between multiple wireless networks, some of which are public and you wouldn't want your shares wide open. –  Ricket Dec 10 '10 at 1:48
    
It is not true. The behavior of OS X remains the same, regardless wether I make a network private or public: If OS X has been elected as Domain Master, then I will see all my Windows 7 machines. When OS X is not, I cannot see the Widows 7 machines. –  Christian Tismer Dec 12 '10 at 0:30
    
Maybe something changes on the windows client side - that is not my concern. I just want to see who uses my network, in any case. And that is what is no longer reliable. –  Christian Tismer Dec 12 '10 at 0:33
    
Computers can always stealth themselves to other computers. If your end goal is to monitor computers connected to your network, you need to do that at your switch or router, not from another client computer. If you can't ping an IP address, does that mean a computer isn't connected at that address? (no; it might mean a computer is there but ignoring pings) –  Ricket Dec 13 '10 at 3:16
show 1 more comment
up vote 0 down vote accepted

The Non-Ideal Solution

After reading a lot of hints, lowering the required client security on the Windows and making the OS X machine the master browser works reliably for me. However, this solution is less than ideal, as it requires reconfiguring the Mac and every Win 7 computer.

Steps

Changes to Windows 7:

  • change the security policy. Using secpol.msc, go to local security, security options and find "Network security: Minimum session security for NTLM-SSP based..." both for client and server. (sorry, may be different, I have a German install).
    • uncheck "NTLMv2 session security required"
    • leave "128 encryption required" checked.

128 bit encryption works with Snow Leopard. Unchecking it is required for some older versions of OS X.

Changes to OS X Snow Leopard:

  • edit /private/etc/smb.conf
  • locate "os level = 2" and change to "os level = 99" which makes this samba always win
  • locate "domain master = no" on next line and change to "domain master = yes"

Starting the new configuration:

  • shut down your OS X and disconnect or shut down all your Windows clients.
  • restart OS X. This way, OS X will become the master browser for samba.
  • restart or reconnect your Windows clients.

The Very Simple Solution

By using OS X Server (properly configured), browsing will "just work", without the need to reconfigure anything else.

  • Get OS X server.
  • Configure SMB as Standalone Server
    • enable Workgroup Master Browser
    • enable Domain Master Browser
    • enable WINS server
  • under Access, allow NTLMv2 & Kerberos, NTLM, LAN Manager (according to what your minimum security should be)

This may be more than necessary, but it made the situation unambigous.

The problem is circumvented. It is not a principal problem of OS X Server, which uses the same Samba build as OS X client. It works reliable with the server solution. Since there is rather little interest in this topic, I will not further investigate, sorry.

About the server cost: It is quite pricey. If you happen to be registered as an Apple Developer, then you can run an evaluation copy of OS X server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.