Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just wanted to make some input where I press a key and the auto-repeat function engages so I don't have to press the 0 key many times to make a long number.

10000000000000000000000000000

This has always worked without fail in the past, but it's not something I do often and I'm not sure where to look next to figure out what might be preventing this.

keyboard - system preferences

I've toggled the sliders to change the delay for key repeat, but the only thing I can hang my hat on is that perhaps Lion disables this with the new feature where you hold down some keys (like the vowels, but also some consonants) to get alternate accented characters.

s turns into ß or ś or š and so on....

Am I missing an obvious setting, or is this something that has moved to a hidden setting or is simply a bug that these controls are still around since key repeat is now deprecated?

Comments welcome if anyone doesn't have an answer, but can provide specifics where this does work for them. I've checked two Macs so I'm guessing it's not related to keyboard type or connection method.

share|improve this question
    
See also: apple.stackexchange.com/a/18837/218 –  Senseful Mar 28 '12 at 4:29

2 Answers 2

up vote 7 down vote accepted

The accented character selection when a key is held was one of the tiny things that changed in Lion. To disable it, run this in the Terminal:

defaults write -g ApplePressAndHoldEnabled -bool false

I will admit, though, it is strange that there's a setting in System Preferences that only affects behavior accessed through a defaults write command.

share|improve this answer
    
I am going to file one heck of a bug report for leaving those controls but detached from the actual on off switch. Thanks! –  bmike Mar 28 '12 at 4:56
2  
The key repeat controls in Lion still affect keys other than letters and numbers — arrow keys, return, delete, function/hardware keys, punctuation, etc. Some apps, like Terminal, will still repeat alphanumeric characters, too. It does seem strange that punctuation and "option" characters allow repeating but not numbers, even though there are no numbers that trigger the popup. –  joelseph Mar 28 '12 at 5:03
    
Wow - a pile of undocumented mess (assuming I can't find this documented now that I know the defaults command) - perhaps that's why it took so long for me to notice with terminal being unchanged. –  bmike Mar 28 '12 at 12:11
    
This command requires a restart to take effect. –  stiemannkj1 Aug 12 at 13:27

As Kyle menitoned, this is a side effect of Lion's new accent feature.

If you have TinkerTool installed, you could easily enable or disable the feature as of version 10.7, which lets you:

Re-enable the key repeat feature

share|improve this answer
    
Thanks guys - I also missed this one... apple.stackexchange.com/questions/23770/… –  bmike Mar 28 '12 at 5:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.