Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPhone 4S, and I've noticed a delay receiving messages. When I've noticed the problem, I've always been on 3G, not Wi-Fi.

I'll generally notice this when 5 or 6 messages in a conversation come in at the same time. From there, everything seems to be real-time with no problems.

I've considered that maybe my 3G service was just inconsistent and is down when the messages are delayed, but my understanding is that if 3G isn't available, the messages will come in as regular SMS.

Anyone heard of this problem, or have any ideas on how I can troubleshoot?

share|improve this question

1 Answer 1

This issue could be caused by a lot of causes.

To start with, it could be a matter of poor data coverage. If you experience the delays at the same time of the day at the same place, maybe that spot isn't that well covered and you just have bad luck receiving messages over there. So if you are always on the same spot, try a different one.

It could also be a connection error. Do you experience the problems when one particular person sends you messages, or with everyone? And do they experience delays too when you send messages to them?

It could be a malfunctioning 3G. Try to turn off 3G (if you can) and just use GPRS. There have been reports iMessages didn't work out well on 3G, but on GPRS it worked like a charm (it doesn't make any sense to turn off and on 3G just to send iMessages, but at least you'll figure out the cause).

And the last, and probably the most unliky cause, could be an issue at the Apple servers. It happens sometimes, when those things get really busy, they protect themselves and spread the work over time. As I said, it's very unlikely, but it happens.

And to answer your second question; yes indeed. If iMessages fails to send, your iPhone will try to send it as an SMS. You can activate this function at 'General < Messages < Send as SMS'

share|improve this answer
    
Thanks for the insight. I've only noticed the problem in one place, but since that's where I'm at most of the day, I'll have to manually test it elsewhere. I don't think I can turn off 3G on the 4S. Nobody else has any delays on these conversations, just me - so I'm pretty sure it's either my phone or my coverage. Maybe I'll stop into the Apple store and have them do a quick checkup on the phone to make sure it's not the problem, and if it's the coverage, there's not a lot I can do about that. Thanks. –  Joe Enos Mar 28 '12 at 14:03
    
Actually, you can turn off your 3G. If you have a jailbroken iPhone, just install SBSettings and you'll be able to turn off 3G and work over GPRS. –  Michiel Mar 28 '12 at 14:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.