Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I downloaded Google Chrome and it automatically changed my default mail reader from Mail to GMail in Chrome. I went to the preferences section of Mail and didn't see an option to make Mail the default reader.

share|improve this question

3 Answers 3

This can be disabled in Google Chrome. Go to Settings, then select "Show Advanced Settings..." at the bottom of the page. Click "Content Settings", and click "Manage Handlers" under the "Handlers" heading. Under "Active protocol handlers", change mailto to "None".

Then go into Mail.app and into Preferences -> General, and make sure "Default E-mail Reader" to "Mail"

share|improve this answer

In theory, it should work as described above. But for me it didn't, so I used RCDefaultApps prefpane to restore the handler for mailto back to Mail.app (on Snow Leopard).

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

My "default mail reader" setting changed and I didn't ask it to! What's worse is that every item in the popdown list in Mail preferneces was a Windows program from my virtual machines, and there were at least 200 items!

I'm on 10.6.8 (still) and after finding that this preference can be set by the BROWSER, I found where it was wonky in the prefs for Firefox. It's in the Applications->mailto popdown in the Preferences panel. Changing it there fixed my problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.