Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an older iPhone that I was thinking about selling soon in order to get a new one. I've set up iMessaging on the device. Normally I would just erase the phone a couple of times and be done with it. But recently, there has been exposed a glitch in iMessaging whereby users continue to receive other user's iMessages, even after the sim card is removed, and the phone is erased.

So I'm curious: is there any way to prevent this from happening?

share|improve this question

6 Answers 6

up vote 2 down vote accepted

There is a workaround for this issue. You change your iCloud account password and enter it on the new device. After that the old device will have your old password, reboot the old device and you have completely circumvented the issue.

Works perfectly for me.

share|improve this answer
    
Interesting idea. Thanks for your answer. –  sudo rm -rf Mar 26 '12 at 17:38
    
Yep it worked for me :) –  Herr K Mar 26 '12 at 19:35
    
There is a residual risk with this method. If one day you change back your iCloud password to this old one, then your old device will recover access to your iMessages. –  daniel Azuelos Jul 18 '13 at 6:23

Go into Settings -> Messages and halfway down choose Send and Receive.
Tap your AppleID on the top of the page, sign out, and let the new guy sign his or her self in.

share|improve this answer

Try this: On the device, go to Settings then iMessage then tap on 'Receive at'. Tap the Apple ID at the top and you get the option to 'Sign out'. No need to change passwords. Should stop messages on that device until you sign in again.

share|improve this answer
    
Thanks for your answer. –  sudo rm -rf Mar 26 '12 at 20:33

This drove me mad... finally worked it out. Not icloud settings but imessage settings:

  1. Tap Settings
  2. Then Messages
  3. Then "Send & Receive"
  4. Ensure that at the top, next to "Apple ID", your ID information is displayed.

If it is still showing someone else's Apple ID, tap it, and choose Sign Out.

Hope this helps.

share|improve this answer

In settings go to messages then select receive at. From there unclick the phone number and this will stop iMessage sharing.. My husband n I share the same apple ID and this fixed the problem with the iOS 6 upgrade No need to turn iMessage off. I tested it n it works. Now remember it only takes a click to start reading each others iMessages again ... This is where trust comes to play...

share|improve this answer

Unregister the old device by logging in here: https://supportprofile.apple.com

share|improve this answer
2  
I don't see an option to unregister a device from iMessage on this page, could you please explain a bit more in detail? –  patrix Jun 13 '13 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.