Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro (10.7.3) and an iPhone 4 (5.1). When I'm trying to conserve outlets, I charge my iPhone at night by plugging it directly into my computer.

If my computer is asleep with the lid closed, when I plug in the iPhone, the computer briefly wakes up, and it takes a few moments before it starts charging. (If the computer is already awake, the charging is instantaneous.) But my computer takes a while to go back to sleep because it saves the contents of RAM (safe sleep).

How can I plug the iPhone it in to charge, without waking up the computer? (And why does this happen in the first place?)

(I've already set up my computer so that iTunes and iPhoto don't launch when I plug in my phone — but this doesn't seem to be enough.)

share|improve this question
1  
Do you want to know why it happens, as you ask in the title, or how to prevent it, as you ask in bold face in the body of your question? Both are good questions, but they're different questions. –  Daniel Lawson Mar 25 '12 at 19:18
    
@DanielL Fair point; I've clarified the question and added the other question as a side note. –  jtbandes Mar 25 '12 at 20:41
add comment

4 Answers 4

up vote 2 down vote accepted

It has to do with connection activity on the USB data lines in a usb cable. For example, I have a Matias Tune Blocker connected to my Mac Pro. When I have the switch set to sync my iPhone, aka its acting as a regular USB data cable for for a USB device, the Mac Pro will wake from sleep as soon as the iPhone is connected.

However when I have the switch on the Tune Blocker set to charge only, eg only the USB power pins are enabled, the Mac Pro will not wake from sleep when the iPhone, etc is connected to the cable. So a solution to keep your mac a sleep when connecting your iPhone would be something like a Tune Blocker, or making a modified USB extension cable that cuts the Data wires for the device plugged into that extension cable.

Matias Tune Blocker Image

share|improve this answer
add comment

You can't - activity on the USB port requires the computer to wake up. If this behaviour was disabled then the times when you do something on USB and want the computer to wake up, it could not.

One time where this would definitely not be desired behaviour is when you plug in a USB keyboard and external monitor in order to use your closed MacBook Pro with the lid closed.

share|improve this answer
1  
… the other time being when you want to charge your Phone ;-) –  Asmus Mar 25 '12 at 8:42
    
Yep - the very technical reason is the PORTSCn register likely has bit 20 set to 1, connect events cause wake up. For phone connection I don't know exactly but expect the USB port requires some configuration to support required charge current. –  Adam Eberbach Mar 25 '12 at 8:49
    
You can, if the USB data pins are disconnected in a wire connected to that port. –  MrDaniel Apr 9 '12 at 15:59
add comment

TwelveSouth offers a product called the PlugBug to charge both devices together.

PlugBug is made exclusively for all MacBook Power Adapters, including current and previous models. Snap PlugBug onto your MacBook Power Adapter and you now have the first ever device that lets you charge your MacBook + iPad or iPhone simultaneously, from one wall outlet.

http://twelvesouth.com/products/plugbug/ Maybe is this something for you!

share|improve this answer
    
Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. –  Daniel Lawson Mar 25 '12 at 21:24
add comment

You could always install Caffeine (App store) to keep the Mac awake and make sure the screen is dimmed right down if you're away from the machine (TBH, burn-in is not much of an issue on modern LEDs). Not ideal, but will work.

share|improve this answer
    
The question asks for a way to prevent the Mac from awakening. Keeping it awake the whole time doesn't solve this issue somehow... –  patrix Aug 4 '12 at 12:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.