Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm seeing a ripple-like interference on an external display attached to my 2010 Mac Book Pro via VGA (Display adapter). This only occurs when the Mac is booted into MacOS X but not Windows. It's intermittent may not happen for a period but then comes in short sporadic bursts.

How can I stop the interference happening? It has only recently started happening in the last 2 months.

Reason for using (analogue) VGA and not digital HDMI or DVI is that I have a KVM switch that shares the monitor with 2 other machines - one of which only has VGA output.

Things I've tried already (still seeing the interference):

  • Eliminate the KVM itself from suspicion - connect the monitor direct to the Mac, via VGA no KVM in between
  • Re-arranged the power plugs of the various other PCs and devices in case there was some kind of earthing issue
  • Disconnected the Mac from the mains, again to see if there was an earthing issue
  • Checked drivers and OS up-to-date
  • Took Mac to Genius Bar at local Mac Store. They made thorough checks and diagonstics and reset "PRAM" etc. They couldn't reproduce my problem on a VGA monitor in-store

Tried to link the issue to hard disc activity or activities on other devices (DVD, blu-ray burners attached, USB3 Express card) but drawing no conclusions.

Since taking to Mac store not seeing the interference so much but it did still happen. Their further suggestions are to screen record to verify if the interference is in the digital domain (i.e. happening on the graphics card) or in the analogue domain (which I think is the case), to boot off the install disc (thinking here is driver issue), to check refresh rates of the monitor and try alternatives if possible.

The fact that I never see this when the Mac is booted into Windows leads me to believe that there is some kind of driver issue in Mac OS X.

Perhaps it is telling hardware to put signals on some pins or paths that cause interference. Or perhaps a flaw in the driver software that is involved with the switching between the discrete and integrated graphics cards (which shouldn't happen anyway because the Mac is always on mains power when it happens).

Thoughts?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Under OS X, open Terminal.app and enter the following command:

defaults write NSGlobalDomain AppleFontSmoothing -int 2

Then, reboot your Mac.

This will enable subpixel font rendering on non-Apple LCDs. This simple tweak solved a lot of display issues for me back when I was using an external Dell display at work. I hope it helps you, too!

share|improve this answer
    
Thank you!I want to upvote you and hopefully accept your answer, I'll try it out very shortly. Can you explain what this does? Do I put this in a start up script or where it run it from, the terminal? Does it have to run every time on boot up? –  therobyouknow Mar 24 '12 at 12:23
1  
@therobyouknow You only need to run this command once. It’s a hidden system preference. –  Mathias Bynens Mar 24 '12 at 12:24
1  
@therobyouknow Good luck! *crosses fingers* –  Mathias Bynens Mar 24 '12 at 12:27
1  
@therobyouknow Don’t get your hopes up — if it’s really an analogue problem this won’t solve the issue. All I know is that I had a lot of weird display interference and color calibration issues with my Dell monitor that all got fixed by this one-liner. “Enabling subpixel rendering on non-Apple LCDs” is what it’s supposed to do, but this setting sure has a lot of positive side effects. –  Mathias Bynens Mar 24 '12 at 12:39
1  
I'm going to accept this answer because I haven't seen the problem since issuing this command. The Genius Bar diagnostics and resets as described may have also helped. But on the whole I hope that if anyone else sees this problem then they should find a solution somewhere on this page, either yours or my attempts prior. Thanks again. –  therobyouknow May 5 '12 at 15:38
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.