Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Finder's list view, you can click the little triangles to the left of folder icons in order to reveal the contents of the folder. In 10.7 Lion, this reveal/expansion is accompanied by a vertical sliding animation.

My problem is (a) the animation slows me down and (b) the animation will often hiccup even on my new i7 Mac Mini with external video card (especially on folders containing many files).

I've searched high and low on the googlesphere for a solution to this, but I've only come across these terminal commands, to no effect:

1

defaults write com.apple.finder AnimateInfoPanes -bool false

No effect on Finder, info panes don't seem to have reveal animation anyway

2

defaults write com.apple.finder DisableAllAnimations -bool true

No discernible effect on Finder

3

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO

This does disable the zoomimg new window animation in all apps, but doesn't affect my issue

Is this an issue for anyone else? Does anyone have a solution?

share|improve this question
    
I have looked as well! -- but have not found a way to do this. TinkerTool currently does not expose a way to help. Nor have I found a way to speed up the animation. Sorry. –  David James Oct 21 '12 at 16:45
    
I'm not sure that 'true' and 'false' will work. Try 'YES' and 'NO' instead. You need to restart Finder after each change. –  Mark Dec 11 '12 at 16:25
    
I retested and it doesn't make a difference, both "YES" and "true" evaluate to a '1' internally (NO/false evaluates to 0) –  beibei Dec 12 '12 at 21:40
    
Did you run those terminal commands as sudo? –  NessyString Mar 20 '13 at 4:23
    
Yes, ran commands with sudo and verified settings changed with 'defaults read' –  beibei Mar 22 '13 at 2:08
show 1 more comment

3 Answers

I've been looking for this solution for quite some time. What this is is an NSOutlineView. The expanding and collapsing of an NSOutlineView now always animates the roll down and roll up of the content and makes you wait for it to finish before you can actually see and use the content. It's infuriatingly irritating that we can not turn this unwanted "feature" off so that it functions as before.

According to a developer at Apple, there is no way to do this and I was encouraged to file a request since this is an annoying addition to the OS that you can not turn of that was not present in previous system releases.

I've reported the bug/usability regression to Apple. It's bug# 14442959.

share|improve this answer
    
Thanks Alex. It's at least nice to know why this is happening. Is there any way to support or upvote your Apple bug report to let them know we are annoyed by this? –  beibei Jul 21 '13 at 1:20
    
When Apple's bug reporting site comes back up, report the bug again. bugreport.apple.com Apple declares this as a standard. I call this a bad idea forced upon the users. The user is now forced to wait for the UI. This means the UI is getting in the way of the user's productivity. This is not what a good UI does. If a feature might do this, the user MUST be allowed to disable this behaviour. –  Alex Zavatone Jul 22 '13 at 15:52
add comment

Tinker Tool might be able to help:

enter image description here

Under Animation effects, it has the following three options:

  • Show animation effect when opening files
  • Animate opening info panels and Desktop icons
  • Animate selecting info panel categories

Perhaps one of these would solve the problem. If you're interested to know what os x setting it modifies, I asked that question here.

share|improve this answer
    
I could be wrong, but panels & categories are quite different from lists. I doubt this would give the desired result. –  sudo rm -rf Mar 23 '12 at 4:52
1  
I tried TinkerTool, but it has no effect on the issue I'm describing. I tried disabling all the animation options under Finder and I also tried Accelerate animation when rolling out sheets under General –  beibei Mar 25 '12 at 20:57
    
It's not a sheet, it's an NSOutlineView. At the time of my writing this, there is no method at all exposed to us (or at all) for us to turn this irritation off. –  Alex Zavatone Jul 19 '13 at 18:23
add comment

Have you tried "Simple Finder" hidden setting? Run the following in Terminal:

defaults write com.apple.finder InterfaceLevel simple

If that doesn't work you may try searching though Secrets, it's a database of these hidden settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.