Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to save a file but get the error message saying file could not be saved. This happens only after the first time I save a new file. That means, if I create a new file saving works. BUt if I try to save the second time, I get the error message.

I also see this error in the Console. Omnigraffle is the application I am trying to save with. I have tried to set the permission on /.vol with no effect.

3/22/12 11:28:06.201 AM [0x0-0x6c06c].com.omnigroup.OmniGrafflePro: [ERROR] genstore_storage.c:GSAddPathAsGeneration:980  copyfile "/Users/xman/gfx/process.graffle" to "/.vol/234881026/2/.DocumentRevisions-V100/staging/adding.gdpTISed/14F74540-E254-4B92-A8EE-B857FD311DB6.graffle" failed with error 13 (Permission denied)

Additionally, I cannot install the new version of Xcode. Not sure if it is relevant or not, but it fails with a generic error.

share|improve this question
    
Try checking your permissions on the /.vol directory. If it's not how you like, a sudo chmod should work. –  CoffeeRain Mar 22 '12 at 13:17
    
You'll need to create a new question for xcode, although if you're installing any portion of it on the server (or trying to open the DMG and save the files to the server) then the issue is likely the same - windows and samba servers don't like OSX file packages. –  Adam Davis Mar 22 '12 at 13:20

2 Answers 2

Omnigraffle attempts to save its files as packages - a format OS X supports, but windows and samba servers do not.

There is an "save this document as a flat file" preference option for each document in Omnigraffle which should resolve this issue and should be used if you regularly save to network shares on non-Apple servers.

http://forums.omnigroup.com/showpost.php?s=c1d4e102eef15890d2c46830044899aa&p=52096&postcount=5

You'll need to change the document properties for each document you wish to save this way:

You can go in to the Inspector for the document, and look in the Canvas accordion pane under the Document Settings tab. There, you will find a heading for "File format options", which by default seems to be set to "Automatic." You can change this to "Save as flat file", and save the document

If you need to do this often, you can change the document templates so that any new documents you create will automatically be flat files:

  1. Go to the OmniGraffle application bundle, right-click, and select "Show Package Contents."
  2. Finder will show you the inside of application bundle. Navigate within the application bundle to Contents => Resources => Templates. In here, you will find a set of OmniGraffle documents that are used as your default document templates.
  3. Open the document template that you want to modify. OmniGraffle launches and shows you the document.
  4. Open the Inspector for the document, go to Document Settings under Canvas, and set the document template file's File Format option to "Save as flat file."
  5. Save the document template.

Now, all new OmniGraffle documents created from that document template will also have their default preference set to "Save as flat file" since the template's preference has been set to that setting.

(via maxim porges)

share|improve this answer
    
there is no such option in the latest version of Omnigraffle which I am using. –  x-man Mar 22 '12 at 15:35

This problem was quite unique and having tried everything, I ended up reinstalling the whole system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.