Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Just updated the iOS to 5.1 this morning and now I cannot connect to the internet. WiFi is not available to me right now...

share|improve this question
    
What happens if you go to Settings → Wi-Fi? Does the network you want to connect to not show up, or do you get an error when you’re trying to connect? Which error? –  Mathias Bynens Mar 22 '12 at 13:13
    
Unfortunately, I do not have Wi Fi access here at my job. But yesterday I did not have this problem in the office...I was able to connect to my email & Pandora with my 3g service. Now all I get is a msg saying "cannot connect to the server" –  wbg Mar 22 '12 at 14:58
    
Ah, so it’s not necessarily a WiFi issue. I’ve undeleted my answer — that’s probably your problem. (I had it too after the upgrade.) –  Mathias Bynens Mar 22 '12 at 15:00
    
@MathiasBynens this is not a wifi specific issue, rather a internet connectivity problem or maybe a 3g connectivity issue? I can receive & send texts + make phone calls - but not use any applications that rely on the internet connection, ie. email, calendar, or pandora. –  wbg Mar 22 '12 at 16:00
add comment

2 Answers 2

You will need to re-enter the network settings. Updating iOS seems to wipe these settings.

Go to Settings → General → Network → Cellular Data Network and enter all fields.


To use a VPN connection, Choose Settings → General → Network → VPN and then choose “Add VPN Configuration”. Ask your company’s IT guy for the credentials.

share|improve this answer
    
I'm assuming it's the VPN info I have to enter? Where do I get the correct information to input? –  wbg Mar 22 '12 at 16:02
    
@wbg My answer explained how to set up and/or reset a 3G or Edge connection. I’ve added some info related to setting up a VPN. –  Mathias Bynens Mar 22 '12 at 16:04
    
thank you for your help –  wbg Mar 22 '12 at 17:35
    
@wbg If my answer was helpful to you, please upvote it and mark it as accepted by clicking the checkmark () next to it. Thanks! –  Mathias Bynens Mar 22 '12 at 17:42
add comment

Try resetting you network settings. Go to Settings > General > Reset > Reset Network Settings. This should do the trick - it did for me.

You will have to enter WiFi keys again, but that's the only downside.

share|improve this answer
1  
Rest the network setting...no such luck. –  wbg Mar 22 '12 at 13:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.