Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I had the sirusxm app on my phone and everytime it would give me problems I would delete it and reinstall it. I forgot that I had just recently changed my email password from my laptop, which is synced with my phone. When I went to download the app after having once again delete it due to having problems, the column which you click on to download quickly changes to purchased. The app is not on my phone. How can I get it?

share|improve this question
1  
How many apps do you have on your phone? Is it possible that you just missed it? Have you tried using Spotlight to search for it? –  jtbandes Mar 22 '12 at 12:25
    
+1 for searching. It may be on an "invisible" page, if you have enough apps installed. –  timothymh Mar 22 '12 at 12:27
add comment

4 Answers

There is a difference between an app that has been purchased and one that is installed. To install a purchased app, open the App Store app on your iOS device.

Click on the Updates button in the lower right corner to advance to the Updates pane:

image of App Store app

Click in the Purchased area near the top of the screen to advance to the Purchased pane:

image of App Store Updates pane

Select the Not on this iDevice tab to see purchased apps that aren't currently installed:

image of App Store Purchased pane

Select the app you're looking for from the list and install it.

share|improve this answer
add comment

When I get to the "Not on this iPod" folder, the app (instagram) I am looking for has an action button that is greyed out. iPod Touch 4th Generation. I have tried to sync via cable with iTunes and no change. I have tried to remove the app from our iTunes and re-sync and also no change.

Background: My niece plugged her iPhone into our iMac a long time ago and some of her apps are on our iTunes and they load to our devices. Instagram was one the apps.

This would seem related to the problem. Unless Instagram is not able to run on an iPod Touch.

share|improve this answer
add comment

Search for it on your phone using Spotlight. As mentioned in the comments, it may be on an invisible home screen. If that doesn't work, you can try using iTunes to sync it over, or at least to help you find it.

If you'r absolutely convinced that it's not actually installed, you can try using a utility to muck around with system files. (Particularly, the SpringBoard property-list files, which may contain info that the App Store is using, although honestly, I doubt that doing so would work.)

share|improve this answer
add comment

Have you tried searching for the application on your device? If you have enough applications installed, some of them may not be shown on the home screen. You can search by swiping to the left from your first page of apps.

You can also check iTunes to see if the app is installed, and uninstall it there:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.