Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Caffeine

Caffeine is a small program. Why is it taking up so much virtual memory or am I reading this wrong?

Edit: persists across application and os restarts

share|improve this question
    
Can I suggest talking to the developer of Caffeine - it might be a bug that they want to fix, or they might be able to shed some light on the situation. –  glenstorey Dec 2 '10 at 22:36
    
i thought may be was misreading it or it was benign, but I guess reporting it would be prudent. –  bronzebeard Dec 3 '10 at 3:37
    
Just out of curiosity - did you ever hear back from the Caf dev? –  glenstorey Dec 10 '10 at 9:07
    
nope, have been too busy of late. I will post an answer if I figure it out/ hear back. –  bronzebeard Dec 10 '10 at 12:32
    
@bronze your RZISE (real memory size), that is amount of memory used by currently allocated objects is only 7.45MB. That’s perfectly acceptable! Don’t worry about “Virtual”. –  Martín Marconcini Dec 11 '10 at 14:34
show 1 more comment

2 Answers 2

up vote 3 down vote accepted

So apparently I was reading it wrong. According to Thomas Franzén ( lightheadsw )

Virtual memory size is a meaningless number for most uses. An application having a big virtual memory size doesn't affect you, because it's just a virtual memory space. The column you should be looking at is RSIZE. That's the actual amount of physical RAM an application is using.

I verified with ObjectAlloc and it seems like it is using only 8MB or so.

Memory test of Caffeine

share|improve this answer
add comment

On my machine, it's using 30.2 MB, so you're right that yours is doing something out of the ordinary.

When you reboot, does it start at a lower number, or immediately jump to this level?
Do you usually have it clicked? (I don't)
Is it adding any messages to your console log?
What version of Caffeine are you running?

share|improve this answer
    
thanks for the quick response, here is what i found. It directly jumps to this number. I have it on all the time. this is the only log message I could find [0x0-0x11011].com.lightheadsw.Caffeine[419] SystemFlippers: didn't consume all data for long ID 0 (pBase = 0x100129f90, p = 0x100129f94, pEnd = 0x100129f98) and I am running version 1.1.1 –  bronzebeard Dec 1 '10 at 6:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.