Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I often want to move files between my MacBook and iMac, but its such an issue that I usually resort to failure. They will see each-other on the network (shown in Finder) but after selecting the machine and waiting a while there will be a message like "connection filed" or similar. The other MacBook in the house doesn't even show on this list at all. So I am wondering is there a secret to getting networking happening, or at least something I can use to troubleshoot these issues?

share|improve this question
add comment

3 Answers 3

First, make sure File Sharing is on for both computers. Then connect an Ethernet cable directly between the two machines. Each machine should appear in the other's sidebar of the Finder. Connect to it by double-clicking (login using your credentials if needed), and then drag your files or folders across at 1Gbps!

Later,

Mike

share|improve this answer
    
I will certainly give this a try. I assume that a crossover cable is required. –  Nippysaurus Nov 30 '10 at 3:12
    
Gigabit ethernet interfaces do auto-crossover, so a special cable is not needed. –  Gordon Davisson Nov 30 '10 at 6:42
add comment

How strong is your connection? I assume you're using wifi on the MacBook? I used to have a lot of issues with this kind of thing until I replaced my wireless router.

share|improve this answer
    
I'm using a D-Link wireless router, which I thought might have been the problem. But now I am using an AitPort Express and am experiencing the same issues. –  Nippysaurus Nov 30 '10 at 3:12
    
does the problem go away or become less pronounced if your macbook is closer to the router? –  Robert S Ciaccio Nov 30 '10 at 3:15
add comment

Either give them both static IP's on the interfaces that are linked with each other, or wait for them both to grab 169.254.x.x IP's. Also make sure firewalls are down or in a "half" state (in Snow Leopard, at least, there's a "firewall on" mode as well as a "block ALL connections" mode - firewall on works well for me, and still offers protection without hindrance.)

Failing that try pinging one from the other, and vice versa. Might have a hardware problem. I would also disable any other interfaces except for the ethernet ones that you're using to connect them to each other.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.