Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a limited 3G plan on my iPhone 4S and I also have iTunes Match service.

In order to keep the phone from downloading songs from iCloud, while under 3G connection, I had set 'Settings>Store>Use Cellular Data' to OFF. This seemed to work just fine until I downloaded the iOS 5.1 update.

A couple of days ago I was surprised to find that while listening to shuffled music, I had ran out of credit because the Music App had been fetching songs from iCloud using 3G, even though the Setting was still OFF.

I've been forced to turn off my 3G every time I want to listen to music on the go, which is really annoying.

Is this a known bug? Is anyone else experiencing the same problem? Is there a fix?

Thanks!

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

You need to turn off "Use Cellular Data" in the "Music" section in Settings. Then, when you go to play a song from iTunes Match when you're on 3G, it'll give you a message saying you need to be on Wi-Fi.

share|improve this answer
    
Thanks, will try this. Is this something new to 5.1? I didn't have this problem while running 5.0. –  pmd Mar 19 '12 at 20:45
    
@pmd Honestly I don't remember, and I don't have any 5.0 devices around to test. Would not be surprised if they changed it though, they did change the 3G download limit from 20MB to 50MB –  Kyle Cronin Mar 19 '12 at 20:47
    
I think it did. I don't remember seeing that option before. Thank you! –  pmd Mar 19 '12 at 20:51
    
Glad I could help! –  Kyle Cronin Mar 19 '12 at 20:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.