Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Often, when I log out of my computer, I'll enable "Reopen windows when logging back in". One of the first things I'll do when I log back on, is swipe over to my fullscreen Xcode project.

The Xcode window immediately exits fullscreen mode and animates back onto my desktop. This is super annoying to me, because the animation wastes time as I try to jump back into my workflow.

Is there any way to prevent the window from shrinking upon becoming active, or at least speed up or disable the animation?

This is nearly useless...

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Disabling the animation

This part of your question has been covered earlier. Unfortunately without success of finding a fitting answer.

Unfortunately (at least as of 10.7.1) there does not appear to be a way to change any settings related to this animation.

I filled a bug for this with Apple. The Radar number is 10073864. I would encourage you to also file the report at https://bugreport.apple.com/. Note in your description that it is a duplicate of the above bug report number to help the support staff categorize and prioritize this bug.

share|improve this answer
    
Only the animation part has been covered. I'm asking about the minimizing altogether. ;-) –  Moshe Mar 19 '12 at 9:19
    
Yes, I know. I'll clarify that in an edit. –  gentmatt Mar 19 '12 at 9:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.