Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Safari has a feature which removes duplicate first words of page titles form tabs, which is useful when sites' pages all begin with the same word or two. "Site Title | Page title 1" and "Site Title | Page title 2" show up as "Page title 1" and "Page title 2," for instance.

However, this can be annoying when two pages have the same first word, but are different, such as the two Ask Different pages, "Ask Different chat - chat.stackexchange.com" and "Ask a Question - Apple - Stack Exchange." These become "Different chat […]" and "a Question […]," which isn't very smart of Safari.

Is there any way I can control this to whatever extent possible?

share|improve this question
1  
Hi, is your question still valid? –  myhd May 22 at 12:51
1  
@myhd I'm not sure…I don't think so, but maybe. I don't know when it decides to truncate now, but the example posed in the question is no longer an issue. If I visit two questions on AD whose first tag is the same, Safari will helpfully remove it, but if I visit "Ask a Question" and "Ask Different", it does not (helpfully). Regardless, it might be worth keeping to see if there's a way to turn it off entirely, not just to prevent erroneous behavior from occurring. –  timothymh May 22 at 16:37
    
What version of safari are you using? It doesn't seem to happen with safari 8.0.6. Screenshot: i.imgur.com/KxTUxpp.png –  nelson2tm Jun 21 at 19:01
1  
@nelson2tm Hm, doesn't seem to be happening for me either. Maybe it has been removed entirely. –  timothymh Jun 22 at 2:21
    
It only happens when there are too many tabs or the window size is small enough that truncation needs to occur. It still happens in Safari 9. (cc @nelson2tm) –  grgarside Aug 10 at 13:16

1 Answer 1

According to this macworld article I don't believe that there is a fix yet (if you really want this fixed, you could try searching for terminal commands to fix or disable this feature). Otherwise you could try switching browsers...

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  grgarside Aug 9 at 16:38
    
Just sending people to an external site without clear indication of which extension you had in mind isn't very helpful. Can you add some details about the extension which will solve the problem described in the question? –  patrix Aug 9 at 19:10
    
Okay, will fix... –  Developer_ACE Aug 9 at 19:14
    
This isn't a solution. There are no options on that page for disabling this. Also, I'm not a bot—these posts were pushed into the Low Quality Posts review queue and I felt that comment was appropriate. –  grgarside Aug 10 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.