Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 2005 PowerBook running 10.5.8 that, in its previous life, was my personal, full time machine that I used all the way through graduate school. It has been relegated to very light duty in the past year, and serves its purpose well. There is one minor annoyance that I'd like to get rid of, but have been unsuccessful so far. The problem is this: it is on most of the day, every day, and roughly twice per day I get a pop up window asking me to select a drive for Time Machine backups. Like I said, this used to be my full-time Mac, and I backed it up regularly so this seemed (at first) to be an artifact of its previous use/state. I do not need to back this machine up anymore and therefore do not need Time Machine on. I cannot get it to stop this behavior. Here is what I have done so far:

  1. Solution: turn off Time Machine backups via System Prefs. Outcome: no dice.
  2. Solution: trash com.apple TM prefs file and restart the computer to reset TM to its default state. Outcome: no change.
  3. Solution: Create a new user account to see if the problem persists. Outcome: it persisted.

So, I am out of solutions. This is a minor problem, as I simply dismiss the dialog box, but it is fairly annoying. Any takers?

share|improve this question
4  
This is a localized problem—not the typical behavior. Which doesn't help when it's happening to you. Is the requestor box asking you to select a drive at seemingly random times, or is it prompting you when a new drive is mounted? –  jaberg Mar 18 '12 at 15:22
1  
Great question - Do you want Time Machine off or on? Have you tried making a new admin user to make sure your "solutions" are not effective due to a permissions issue where your current user can't re-write some system files that track Time Machine? –  bmike Mar 18 '12 at 15:53
    
Awesome - if you would edit your question and the best answer, that would be ideal. Otherwise, I'll try to clean things up. There's a fine line between having good troubleshooting preserved and just putting that into the Q and A and we're all over both sides of that line at present. –  bmike Mar 18 '12 at 16:40
    
Agreed. I have edited the OP with comment info and have deleted respective comments. I'll select best answer within 24h when I know for sure if things are square. –  soxman Mar 18 '12 at 17:22

2 Answers 2

up vote 3 down vote accepted

If you're referring to the nag when you plug in a new disk, you can try the defaults setting mentioned here:

defaults write /Library/Preferences/com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool YES

Alternatively, try decreasing the interval of backups to some insanely great number. Try the opposite of the setting listed as #26 on this page:

defaults write /System/Library/LaunchDaemons/com.apple.backupd-auto StartInterval -int 1800

You might try this to have TM prompt you once anually:

defaults write /System/Library/LaunchDaemons/com.apple.backupd-auto StartInterval -int 31449600

You might need to use sudo to apply these settings.

share|improve this answer
    
The command DoNotOfferNewDisksForBackup -bool YES did not work, unfortunately. I am going to set the LaunchDaemons default to annual intervals like you suggested, which should no doubt do it. Thank you for your help! –  soxman Mar 22 '12 at 5:17

How about using the following Terminal command:

defaults write /Library/Preferences/com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool YES
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.