Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Each time I open System Preferences, I authenticate and turn on Enable Location Services. The check box appears to turn on, but if I close System Preferences and look, it's off again.

When this happens, this is logged:

12-03-16 10:06:37.206 AM [0x0-0xee0ee].com.apple.systempreferences: ERROR,Time,353610397.205,Function,"CLInternalSetLocationServicesEnabled",CLInternalSetLocationServicesEnabled failed
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,1   CoreLocation                        0x00007fff8b2b77be CLInternalSetLocationServicesEnabled + 110
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,2   Security                            0x000000010effc65c SecurityPrefDebugLog + 4356
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,3   CoreFoundation                      0x00007fff909c075d -[NSObject performSelector:withObject:] + 61
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,4   AppKit                              0x00007fff88adecb2 -[NSApplication sendAction:to:from:] + 139
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,5   AppKit                              0x00007fff88adebe6 -[NSControl sendAction:to:] + 88
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,6   AppKit                              0x00007fff88adeb11 -[NSCell _sendActionFrom:] + 137
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,7   AppKit                              0x00007fff88addfd4 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 2014
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,8   AppKit                              0x00007fff88b5dd04 -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 489
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,9   AppKit                              0x00007fff88adcbde -[NSControl mouseDown:] + 786
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,10  AppKit                              0x00007fff88aa76e0 -[NSWindow sendEvent:] + 6306
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,11  System Preferences                  0x000000010a238a17 System Preferences + 31255
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,12  AppKit                              0x00007fff88a4016d -[NSApplication sendEvent:] + 5593
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,13  System Preferences                  0x000000010a237c61 System Preferences + 27745
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,14  AppKit                              0x00007fff889d61f2 -[NSApplication run] + 555
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,15  AppKit                              0x00007fff88c54b88 NSApplicationMain + 867
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,16  System Preferences                  0x000000010a232d9c System Preferences + 7580
12-03-16 10:06:37.208 AM [0x0-0xee0ee].com.apple.systempreferences: STACK,Time,353610397.205,17  ???                                 0x0000000000000002 0x0 + 2

What do I need to do to turn on Location Services?

This is an iMac7,1 running 10.7.3. I've tried turning on location services with every release, and it hasn't worked yet. WiFi is on, though I'm connected via a wire since I'm on the edge of my range here.

share|improve this question
    
@daviesgeek: Isn't OS what tags are for here? Is there a discussion on this that I should read? :) –  Steven Fisher Mar 16 '12 at 17:19
    
Yes, but since both iOS and OS X devices support Location Services, I edited your title to include "OS X", since that explains your question better. If you don't like it, feel free to rollback. I don't have any problem with that. –  daviesgeek Mar 16 '12 at 17:20
    
No, it's fine. :) I was just wondering if I should make a habit out of putting the OS in the subject. Sounds like it can't hurt. –  Steven Fisher Mar 16 '12 at 17:35

1 Answer 1

up vote 2 down vote accepted

Could be related to this bug:

Running the iPhone simulator via Xcode disables the Mac's location services.

Do you have the iPhone Simulator running?

share|improve this answer
    
Oh, you're GOOD. :) That's it. I'll accept your answer as soon as StackExchange lets me. –  Steven Fisher Mar 16 '12 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.