Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Scenario:

  • I have a Mac running OS X Lion, and then VMware Fusion 4.x running Windows XP and Windows 7 as virtual machines.
  • I use a Logitech MX310 Optical Mouse. It has 6 buttons and I think it's the greatest mouse ever invented and I own a few (one is at the office). What I especially like are the back and forward buttons.
  • If I use the MX310 under native Windows (I have a PC, too) the buttons naturally act as the back and forward actions in Windows Explorer, Internet Explorer, Firefox, etc. to navigate backwards and forwards within folders, web pages, etc.
  • When I use the MX310 on the Mac, I install the Logitech Control Center preferences pane, which makes sure the buttons also work as expected within Finder, Safari, Firefox, etc.

Problem: When running Windows (whether XP or 7) as VMs under VMware Fusion, the MX310's back and forward buttons no longer work in Windows as they are supposed to. Under Windows XP, nothing happens. Under Windows 7, they have the effect of moving and resizing a window to occupy the left half of the screen, or the right half of the screen (depending on the button pressed.) So, I think there is a signal getting sent to the VM, just the wrong one.

How can I get the back/forward buttons working properly within my Windows virtual machine instances under VMware Fusion? I'd even be happy with some key/button re-mapping kludge running under the Windows VM that simulates what they're supposed to do in the first place .. but something that gets VMware Fusion sending the right message would be better.

share|improve this question
    
Have you also posted this question on the VMWare Fusion customer support forum? They are very helpful over there. communities.vmware.com/community/vmtn/desktop/fusion –  Wheat Williams Mar 16 '12 at 16:46

4 Answers 4

up vote 3 down vote accepted

I've fixed this my using Fusion's "Key Mappings" feature. CajunLuke is correct: Windows was receiving "Win+Left" and "Win+Right", I simply re-mapped "Cmd+Left" to "Alt+Left" and "Cmd+Right" to "Alt+Right", and Explorer et al. seem to work correctly now.

share|improve this answer
1  
To clarify: in Fusion's "Key Mappings", you must map COMMAND+Left and COMMAND+Right to Alt+Left/Alt+Right. –  Chris Jun 19 '12 at 16:23

It seems like VMware is sending the buttons to Windows as Win- and Win-. Go to VMware's preferences (as opposed to the individual VM's settings) -> Keyboard & Mouse toolbar tab -> Mouse Shortcuts tab. You may be able to modify the settings in there.

Alternatively, you may be able to change the keypress generated by the mouse button in OS X on a per-app basis and change it to do what you expect when VMware is active.

share|improve this answer

To expand on what CajunLuke said about changing the configuration on a per app basis.

If you have Logitech Control Center for OS X installed you can use Advanced click settings for just VMFusion using the following steps.

  1. System Settings > Control Center

enter image description here

  1. Click the Plus button next to the global settings drop down and navigate to VMFusion and click select

  2. Change Thumb Back button to Advanced Click with the button 4 option and Change Tumb Forward button to Advanced Click with the button 5 option.

enter image description here

I use win + left and win + right for screen snapping in windows, so key mapping was not an option for me. Advanced click allowed me to keep the windows shortcuts intact as well as use my forward and back buttons on my Anywhere Mouse MX as intended. I have tested this in Win8 full screen and single window and it works beautifully. I'm not sure about unity because I haven't used Win8 in unity mode so I did not test. Hope this helps others. I know it took me forever to find the anser I needed.

share|improve this answer
    
Just to note: it does not work in unity mode. Probably because VMWare registers each app differently from VMWare Fusion settings. –  user23127 Mar 31 at 11:00

Please note that the solution above - "If you have Logitech Control Center for OS X installed you can use Advanced click settings for just VMFusion" - causes 5-10 second hangs with Mac OS X Mavericks + VMWare Fusion 6 when switching between VMFusion (a particular set mouse settings for VMWare Fusion only) and another Mac OS X program (the global set of Logitech mouse for all other programs). It seems that the problem is the current (latest) version of Logitech Control Center's incompatibility with Mavericks - it worked OK with Mac OS X Mountain Lion (no hangs) but not anymore with Mavericks.

I got around this by deleting in the Logitech Control Center the VMware Fusion specific settings and using only the global/general settings. I then used VMware Fusion's "Key mapping" function (as mentioned above) to remap the keys and it works fine now.

(Thanks to VMware support who have been great with looking into the hangs and then it now turns out that the problem is not VMware Fusion but Logitech's software.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.