Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been trying to use an Apple Bluetooth Wireless Keyboard with my Windows 7 PC (My own build, not Apple hardware). If I stop typing for as few as 10-15 seconds, when I start typing again and if I type continuously, there is a lag of 3-5 seconds before the text shows up on the screen. If I type a few keystrokes and then stop, nothing happens. However once I start typing again, all of the previous keystrokes are sent at once.

I'm not sure if this is a driver issue or a problem with my bluetooth adapter. In Device Manager, it shows 2 Keyboard Devices; 1 on Blutooth HID Device and another on USB Input Device (Logitech Download Assistant). I am not sure what the Logitech one is. I do have a Logitech Performance MX Mouse, but why that would be under Keyboards, I don't know. Under Bluetooth USB, it shows my Bluetooth adapter from IVT Corporation, Driver Version 6.2.71.213 from June 24, 2010.

How do I fix the 3-5 second lag when typing with an Apple Bluetooth keyboard on a Windows 7 PC?

share|improve this question

2 Answers 2

The frequency of 2.4 GHz Wi-Fi overlaps and can interfere with the Bluetooth frequency that is going to the keyboard to the Mac.

Some PC have better response with this fix:

You just need to go into your Wi-Fi settings by going into the browser and entering the router's IP address (usually "192.168.1.1"). Enter the username and password when prompted. There should be a wireless setting for your wireless frequency, called 'channels' and normally is put the 'automatic' you just have to change that from 'automatic' to 'channel 1' this should out your router to the lowest frequency. After saving the settings just to be sure turn off the router for 30 seconds and check your keyboard if it is working (may need a restart of the iMac and the keyboard). This should resolve the problem.

share|improve this answer
    
This could be a great troubleshooting step and if fixing the channel avoids interference it might also be a great fix. My guess is it depends heavily on the hardware, location and exact nature of the drivers and antennas for both the computer and the keyboard. –  bmike Mar 17 at 19:25

It seems there are a lot of people having the same issue.

On Apple Discussions they suggest you pair your keyboard with the machine, so it won't be interfered with by another device.

On TechSupport Forum they talk about a sleeping mode of your keyboard in your Windows settings.

And on YouTube , there seems to be an easy fix for this.

share|improve this answer
    
Hmmm.... yeah I had seen those but they didn't help me. The options weren't available to me, likely because of my bluetooth device. Regardless, I have upgraded the driver and software (Not sure why additional software was needed) and that seems to have done the trick. So I'll put this up here just in case anyone else runs into the same issue. I was using Version 7 of the BlueSoleil software and I updated it to Version 8 which seems to have done the trick. But thank you for your help! –  Sugah Shane Mar 24 '12 at 9:21
    
If you've found the solution, you should post it as an answer and accept it. Please read about accepting answers. You can also read about accepting your own answer. –  SSteve Jul 26 '12 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.