Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I want to buy a new MacBook Pro, from Apple. However I want to run Snow Leopard instead of Lion.

I did some Google searches and found a few success stories of people who got SL to run on their early-2011 MBPs. I didn't find much of any experiences of people doing the same on a late-2011 MBP though, so I'm wondering (and really hoping!) if it's possible?

share|improve this question
    
Why don't you want to run Lion? It's much better than SL. –  CajunLuke Mar 13 '12 at 21:18
1  
@CajunLuke I don't care much for "fullscreen mode" apps or Launchpad. Resume is also not particularly interesting to me. Autosave and Versions may be nice ideas but they are either not yet fully matured features, or were never intended to accommodate power users such as myself. The list goes on. Lion is overall a much more appealing upgrade to casual users than it is to experienced users. I don't oppose the ideal of simple user interfaces, but a good UI also adapts and scales to the pace of the user. Which is something that OS X definitely does, but less so in Lion. In my opinion. –  hawk Mar 13 '12 at 22:16
    
I'm an experienced Mac user and I find Lion to be worth the upgrade. I rarely use fullscreen and I never use Launchpad or Versions. The autosave and reopen simply means all the apps work the same way: Eclipse, Xcode, and BBEdit have always reopened the last documents you had open when you quit, so why shouldn't Word, TextEdit, and Excel? Even if you don't use the features you mentioned having no interest in, it's still a much better OS than Snow Leopard. –  CajunLuke Mar 14 '12 at 15:23
    
And I disagree that it's more appealing to casual users - I can't talk my dad into upgrading his Mac to Lion even after he bought the upgrade because there really aren't any features he'd use. In my daily use (as a power user) I use Lion features all the time, particularly Mission Control which removes the idiotic distinction between Exposé and Spaces so Spaces is actually useful. –  CajunLuke Mar 14 '12 at 15:27
    
I just updated my home iMac to Lion from SL and I'll never go back. Even my spouse loves it and she's a stick-in-the-mud luddite. Now that Mountain Lion.1 has been released, I'll be upgrading yet again! Like CajunLuke, there are a lot of appealing new features except for the absurd reversal of the scroll-wheel direction. Good thing this can be put back to 'normal.' –  IconDaemon Aug 23 '12 at 19:09
add comment

4 Answers

up vote 3 down vote accepted

I'd like to confirm that it IS possible to run Snow Leopard on a late 2011 MBP 15" without ANY FLAW although AppleCare technicians told me that it is not possible ! I did it on mine (CTO, 2.2 GHz i7) bought in fev. 2012 and had not the slightest issue since.

But from Apple side it is NOT recommended and certainly NOT supported . - But hey, my love and I have some scientific software and also Adobe products that only run smoothly on Snow Leopard and all our other Mac's in the family are on SL so I had to give it a try to stay productive. And personally, I'm not really happy with Lion, but that's an other story. - For me it's just roaring and definitely not the 'King' of the MacOs as the name suggests...

So here is what I did :

  • As I couldn't lay my hands on a original MBP 15" Install-DVD from last summer (10.6.7) which should allow you to boot the MBP15" directly from it, I did a clean 10.6.7 install with my iMac 27" (iMac11,1 - i7 2.8 GHz) on an external hard drive starting from a 10.6.3 iMac install DVD and applying all the updates up to 10.6.7.
  • Then I formatted my MBP internal drive in target disk mode and created 3 partitions (SL, Lion, Bootcamp).
  • Using CarbonCopyCloner I cloned the clean SL installation one the first partition of the MBP, then disconnected the laptop and booted in SL.
  • There was one little glitch with the splash screen resolution (not full screen) but nothing serious.
  • Now I ran the 10.6.8 combo update that I downloaded before cloning and did all the software updates and another reboot.
  • That done SL runs now without any problem - not one incompatibility issue in one month (would have been surprised because there were no major hardware changes from early to late 2011 MBP15").
  • As next step I rebooted the MBP holding the alt-command-R keys to start from the Apple servers and did a new Internet install of Lion on the second partition.
  • And last I installed Windows 7 on the third partition reformatting it using NTFS (be careful to choose the right partition - by the way there is a fourth partition : the rescue partition created by Lion you don't want to touch). Once Win7 installed I ran the Bootcamp Assistant and did all updates.

And so now we have a nice triple boot MBP15" allowing us to use all the software we need without the slightest problem. You could probably even try a quadruple boot adding a Linux partition...

But be careful! I wouldn't bet that this method works for all new MBP and MBA so you want to make sure your model ran with SL back in summer 2011 and had no major hardware changes before trying! You can also test booting it first from an external drive with the clean install on it.

I neither do know if my method worked because the iMac 27" and the MBP15" both have a i7 Quad Core.

that's it, have fun!

share|improve this answer
    
I did it similar to your way, except I don't have a boot camp partition and I installed all the updates with my 2008 iMac. I booted from the external drive connected to the 17" late 2011 MBP and it worked without a single problem! I did not even use the specific install disk for the early 2011 version of this MBP, I simply used the generic SL disk I bought in the Apple store in 2009. –  hawk Apr 18 '12 at 22:30
add comment

Snow Leopard could run on early 2011 machines because those machines were originally released with Snow Leopard.

However, since yours is a Late 2011 model, a build of Snow Leopard that is compatible with your machine's hardware has never been engineered and thus would not work.

If you look at the kbase article, you can see that all the Late 2011 model MacBooks Pro came with 10.7.2. Snow Leopard would not know what to do with these machines.

share|improve this answer
1  
Thanks. I know what you're saying, but apparently the Early-2011 and Late-2011 are very similar, both internally and externally. I noticed this by comparing the specs on everymac.com MBP 17" Late 2011 : MBP 17" Early 2011.That observation is confirmed on a Q&A page too. It makes sense because the late-2011 models were “quietly announced” by Apple, hence it was a minor update. So I'm hoping that, in this instance, the HW is similar enough to make no significant difference to Snow Leopard. –  hawk Mar 13 '12 at 20:44
add comment

Here's one page which claims that Snow Leopard can be installed on a Late 2011 MacBook Pro by using the install discs of a matching Mid-2011 model (follow the link to the full page for more detailed instructions):

After getting fed up with OSX Lion and the way it handles network shares and attached drives, I decided to look into putting Snow Leopard on my (new) Late 2011 Macbook Pro. Apple said it was impossible due to lack of driver support, but I did not believe them. After making a checksheet of OSX disc releases with MacBook Pro models, I realized that the discs shipped with the Mid-2011 MacBook Pros would boot on my laptop (OSX version 10.6.7). (These discs are rare, and you MUST have the one that accompanies your MacBook Pro model, e.g. a 13 inch MBP must have the 13 inch discs, etc). Finding these discs is the tough part. After finding the discs, just due what you would normally do to install OSX.

Source: http://news.imodzone.net/2011/12/snow-leopard-on-late-2011-macbook-pro/

Also, this article may be helpful: “How to install Snow Leopard on a brand-new Lion-based Mac.”

As pointed out by Matt, installing Snow Leopard on the Late 2011 MacBook Pro is not officially supported by Apple, so there's no guarantee it will work. If you really need to be able to run Snow Leopard, you may be better off buying an older MacBook Pro; either second-hand or a refurbished one directly from Apple. The US online store's “Refurbished” page currently lists a number of MacBook Pro offers that were “Originally released February 2011.” These will come with Lion pre-installed, but will presumably still be guaranteed Snow Leopard-compatible (but ask Apple before buying just to make sure).

share|improve this answer
    
This is a good find! However, I'd be wary of doing this. You won't have the correct build on your machine and you may run into strange software issues. Just a heads up! –  Matt Love Mar 13 '12 at 18:21
    
Thanks Rinzwind. I'll investigate on the feasibility of finding a SL install disc (or disc image, which should equally work – if it works at all) of an Early 2011 MBP 17". Your other link points to an article which was actually written in July of 2011 (the late MBPs came out in the end of October) so that isn't necessarily indicative of how (or if) it would work for the Late 2011 models. Quite the opposite: if that man had to go thru all that trouble to install SL on an Early '11 MBP just because it came preinstalled with Lion, ... I think Apple puts in specific checks to prevent downgrading. –  hawk Mar 13 '12 at 20:56
add comment

I would recommend a triple boot - SL, (Mountain, etc) Lion - Bootcamp for Windows XP - 8 as recommended to me by a member of Virgin Media staff. It is the option I'm going for and would recommend. I might even get Windows to boot of a second HD installed in place of the CD drive.

share|improve this answer
1  
Please come back and edit in your success. I edited out a lot of not exactly on topic information since we like very targeted answers here. With all the good answers that exist, you'll want to bring a good edit to improve an answer if you don't have some new ground to break on how to get SL running on say a 13 inch retina Mac where it's not at all clear the drivers to run it are even available. –  bmike Nov 2 '12 at 16:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.