Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to upgrade my iPhone running iOS 4.1 to 4.2, iTunes displays the error message saying:

There was a problem downloading the software for the iPhone "[Username]'s iPhone". You do not have enough access privileges for this operation.

I kept trying the upgrade process repeatedly, but with no luck. Everything else, including app and music downloads, works fine. I'm running iTunes 10 on MacOS 10.6. What do I do?

share|improve this question
up vote 2 down vote accepted

I found a fix on the Apple Discussions board:

  1. Go to ~/Library/ (i.e. open your home directory, then select the Library folder)
  2. Get Info (click File -> Get Info or type ⌘I)
  3. If possible, make sure the lock at the bottom right corner of the Get Info window is unlocked
  4. Make sure the Sharing & Permissions: section is visible
  5. Where it says "Username (me)" make sure the privilege is set to Read & Write
  6. In the little tool/wheel pulldown right below, select Apply to enclosed items (say yes, if it asks you if you know it can't be undone)
  7. Try the upgrade again

This worked for me. Hope it helps!

share|improve this answer
Superb! worked a treat for me, thank you – user5142 Apr 8 '11 at 1:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.