Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am in my iTunes library (not a playlist) and have "shuffle" turned on (songs, not albums). If I click on "play", it plays the song currently highlighted, then stops (it does not play another song afterwards).

The only way I get it to play several songs is by manually checking the songs I want to be played. Which obviously is the opposite of random shuffling.

Also, when I turn off shuffle, then turn it on again, I don't see any change in the order of songs in the library (whereas when I'm in a playlist, I do see a change in the order).

In all the help forums, I've only found answers to the question of how to turn "shuffle" on. I know that. But how do I get iTunes to play songs randomly once shuffle is turned on?

share|improve this question
1  
What version of iTunes? What platform? This is not the behavior I get when I perform these steps in iTunes 10.5.3 on my Mac. –  Daniel Lawson Mar 11 '12 at 23:02
1  
What about iTunes DJ? –  segiddins Mar 11 '12 at 23:22
    
iTunes shuffles once on the song you first select, but if you select anything again it won't reshuffle. Also, is it possible that you don't have Repeat All on for your main library? (the settings can be different between playlists) Lastly, the main library doesn't shuffle, only playlists do. –  Lucas Derraugh Mar 11 '12 at 23:45
    
@LucasDerraughhe Tracks don't visibly move around, but it does shuffle play. –  timothymh Mar 12 '12 at 0:34
    
@Daniel L: I have 10.5.3 on iMac OS X 10.7.3 –  Ralph Mar 12 '12 at 18:05
show 4 more comments

1 Answer

When iTunes shuffles through a playlist, library, or other list, it only will shuffle among items for which the "checkbox" column is checked. By default, this would include all the items in your library; only if you uncheck the box for a song would that remove it from the list of songs to shuffle.

It sounds as though your library is set up with all the songs unchecked. If no songs are checked to be included in shuffle, one gets the behavior you describe. The solution is to go to your library and make sure all your items are checked, not unchecked.

share|improve this answer
    
No, all the songs are CHECKED in my library. It is exactly the same as normal. Shuffle is turned on, and nothing is happeneing. I have the same problem. I turn it on and off again, and the order stays the same. This has nothing to do with the 'checkbox' –  Ralph Dec 11 '12 at 3:40
add comment

protected by Community Dec 11 '12 at 6:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.