Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

With auto logout enabled, I experience severe display errors at the login screen. These errors do not occur at the login screen right after boot. They appear only when the auto logout is triggered.

I wonder if it's a hardware bug. A major flaw has been discussed at discussions.apple.com (166 pages!!). However, that bug is different and happened with Nvidia GPUs. I have a AMD Radeon HD 6490M (early 2011).

Question

  • What causes this bug? (hardware? software?)
  • What measures should I take?

enter image description here

enter image description here

share|improve this question
1  
I still have this and have never had FileVault enabled. I think the common thread is auto-logout. But I've never had crashes. –  afragen Mar 10 '12 at 18:07
    
@afragen Do you also have Radeon graphics? –  gentmatt Mar 10 '12 at 18:25
1  
ATI Radeon HD 4670 256 MB –  afragen Mar 10 '12 at 20:10
    
@afragen You're right, now I also experience this without FileVault enabled. –  gentmatt Mar 12 '12 at 9:17
    
I have the same thing on my iMac 2011 with FileVault 2 enabled, refit enabled (on efi partition), 20G ram –  user26887 Aug 6 '12 at 19:48
show 1 more comment

2 Answers

up vote 3 down vote accepted

Problem solved

In System Preferences > Energy Saver the timers for display sleep and computer sleep must be greater than the time of auto logout after inactivity in System Preferences > Security & Privacy.

share|improve this answer
    
Seriously - this is amazingly bizarre. Have you made an Apple developer account so you can submit this as an official bug using Radar? Reproducable reports of things like this are invaluable to the engineers that work to fix these driver issues. –  bmike Mar 12 '12 at 14:43
    
@bmike I don't have a developer account, so I can't submit this bug. –  gentmatt Mar 12 '12 at 18:32
1  
I'll poke at this today and see if it's reproducible... –  bmike Jun 24 '12 at 13:40
add comment

I don't get automatically logged out (or at least none of the settings to do so), no file vault, etc, but I have just started to get this; from yesterday afternoon and over night this has started to happen.

I upgraded to Mountain Lion about 1 month ago (followed by Parallels Desktop and a couple of other things) and haven't (so far as I know) installed any new software since then. At least I have not had to enter my password to install anything.

Running an iMac with AMD Radeon HD 6970M.

I put it to sleep and turn off my magic mouse, as always. Then after "some" time the system wakes, I am logged out, the system has no mouse connected so shows the message and I get a screen with my (logged in) desktop and the redraw behind the cursor (once my mouse it turned back on). I can then log in.

It has always turned itself on or made odd noises but only very occasionally and has never logged me out before.

I guess I need to find whatever it is that is logging me out whilst the system is asleep and sort that out! Oh the joy... just what I needed to do today.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.