Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have, in iCal two accounts: one local, one synced with my Google account. In the last 3 weeks or so, the alarms on the synced account have stopped working -- that is, I'll create an event, set the alarm, and click "done," and when I click on the event immediately after, my alarm settings have disappeared. This also happens when I add an alarm to existing event on this account. The alarms on my local account appear to be working fine.

I am running 10.6.8 on a 15" MacBook Pro.

Has anyone else had any problems like this? Any ideas as to how I could about fixing it?

share|improve this question
    
You are not the only experiencing this problem. I have Snow Leopard on my iMac, and I am having the exact same issue. –  user20027 Mar 12 '12 at 19:06

2 Answers 2

On snow leopard I find that iCal drops alarms of type "message with sound", which I assume is because google calendar doesn't support them. It works ok for me with alarms of type "message". Could that be your problem?

share|improve this answer
    
This doesn't help. –  Artur Bodera Nov 21 '13 at 15:02

Yes!!! I have exactly the same problem. It worked all the time and a few weeks ago it stopped working :(

I found something which does not work for me but eventually for someone of you:

"Mike Riordan Re: iCal - alarm problems after upgrading from Tiger to Snow Leopard. 11.03.2012 09:27 (in response to Robby W) I've been having the problem with no alarms in Lion and have finally resolved the problem. The suggestion to check preferences and the disable the alarms checkbox, it's not the only one. I have found that each calendar has the ability to disable it's own alarms. To check this, pull down the calendars and control-click the calendar that has your alarms. Then select "Get Info". You'll see that there's a disable alarms checkbox for each calendar. That was selected and fixed my problem,

I think this got checked when I was trying to set up sharing. One of the sharing option was to disable alarms. I didn't want my alarms going off on someone else's iCal, so I checked it."

share|improve this answer
    
I tried resetting the individual calendar alarm options in iCal -- it WAS "off" -- but it's still not working. The event syncs with Google and then resets itself to no alarm. Frustrating! –  user31092 Oct 1 '12 at 19:24
    
I have the same problem as user31092, using OS X 10.7.5 on a 13" MacBook Pro. I can delete the default alarm, but once I do it's impossible to add another one. –  user49809 May 21 '13 at 19:40
    
Mike Riordan It worked. I don't know what I did but I kept trying and did what you said and now if I add a calendar date in our family google cal on the mac ical i can add the reminder. Lets hope it went to everyones cal on their phones. Worked on mine now when my children come home I will see if it added the reminder to their phones :) Thank you!! –  user69146 Jan 31 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.