Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having the following problem! My fonts get replaced in multiple programs (E.g. twitter, itunes, tweetdeck) It all looks like the screenshot I added below. I don't know how this came all of a sudden and it's really anoying, does anyone know what I can do to solve this problem?

I tried: rebooting and resolve standard fonts in font-book.

Thanks a lot!

font get replaced

share|improve this question
up vote 1 down vote accepted

Get Onyx, go into Cleaning -> Fonts, check all, Execute.

If that doesn't work, check your disk for errors. If it still doesn't work, your fonts are are missing or corrupt - reinstall OS X.

share|improve this answer
You could also use the Apple Type Services utility: sudo atsutil databases -remove; sudo atsutil server -shutdown; sudo atsutil server -ping – user495470 Mar 8 '12 at 9:27
Tried onyx, it worked! thanks a lot! – Tim Mar 8 '12 at 9:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.