Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have 2 external USB drives connected to my iMac running 10.7.3. One is designated completely for Time Machine use and the other I use for data. (Nothing but a bunch of JPGs on that one.) The first spins up once an hour for Time Machine backups, great. But both of them spin up at random times while I'm doing, well, ordinary stuff, nothing disk-related. Maybe just switching to another app in the dock, or surfing to a new web page.

Spin-ups for no clear reason are a bit annoying, but I can accept them as long as I can continue working. But in some cases, the spinning pizza cursor appears, and I'm locked out from doing anything while the cycle completes. That does not make sense to me. It's a multi (4) processor, fully multi-tasking system. All I/O should be asynchronous. Finder/GUI operations should not be affected.

Any ideas why these random spin-ups occur? How to search or instrument MacOS to find out why? How to limit or stop them?

Disconnecting or un-mounting the external disks will work, but is not an acceptable fix.

share|improve this question
3  
With a zero % percentage acceptance rate you will probably not get the quality of answer you are looking for. I would recommend going back to verify you truly have no questions that have been answered in a meaningful way to better increase the chances of receiving good answers. –  Mort Dec 5 '12 at 22:08
    
"Random" does not mean "something I don't understand." –  Daniel Lawson Dec 6 '12 at 0:17

2 Answers 2

The obvious solution is to deselect the "let idle drives spin down" and you won't have yielded control of this to the OS.

The vast majority of people unmount the drives when this behavior is troublesome, so I'll add that in case someone else has a similar issue, but not as strict a stance on "Disconnecting or un-mounting the external disks will work, but is not an acceptable fix."

In your specific case, you could run fs_usage and see if you can correlate which IO pattern and program is initiating the spin up and armed with that information, you could potentially nip the cause in the bud.

share|improve this answer

This problem has been happening since January 2010, according to users on this Apple Discussion forum. While no fix has been identified, two potential culprits were identified:

  • Spotlight - one user (loayza) noted:

I also have the issue (SL 10.6.8). I have an external drive to handle TimeMachine and every time I select "Open with" from the contextual menu it wakes it up. It's quite annoying! It seems disabling Spotlight solves the problem...

  • iStatPro - one user (jrawl004) noted:

I found the culprit. iStatPro.....I have a habit of tracking my system status while editing video and this program does a great job at keeping things up and reportig. So everytime I made the slightest touch to my iMac or MacMini, it would awake everything so it can report. I disabled the widget and low and behold, things became extremely quiet quickly. That problem is solved for now....for me at least.

No solution was identified when checking Apple Support's KB.

share|improve this answer
    
Thanks! I don't have iStatPro. I told Spotlight (through Control Panel --> Spotlight --> Privacy) not to index either drive. Got a message that Spotlight can't be stopped from indexing the TM backups on the one drive. I'll report back results in a couple of days. –  hen3ry Mar 8 '12 at 1:37
    
Suppose that Spotlight is the culprit. Still doesn't explain why the UI is locked out in some cases. Does this suggest a second mechanism? –  hen3ry Mar 8 '12 at 4:06
2  
Nope. I told Spotlight to completely ignore my freshly-formatted second external HD. (The first is used by TM.) Just now, as I moused to the dock it was spun up. There is absolute no reason I can think of for this to occur. There is NOTHING on that drive. –  hen3ry Mar 8 '12 at 6:58
1  
I found another culprit: I had not noticed that the latest version of SMARTReporter had default settings that spins up external USB HDDs every 10min to check their status. In my case the single external HDD isn't even S.M.A.R.T-capable, so this looks like totally wasted motion. I excluded that drive and things are now much quieter. Hooray! –  hen3ry Dec 12 '12 at 5:22
    
@hen3ry, terrific! Glad you found the issue that was causing the USB HD noise. –  JW8 Dec 12 '12 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.