Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Has anyone seen this? Let's say I set my screen saver to activate after 5 minutes. Well I can be typing and using the mouse almost continuously for a period of time (5 minutes? I'm not exactly sure) and all of the sudden the screen saver turns on. If I'm in the middle of typing the screen saver then goes away almost instantly but I lose a few key strokes.

Is there an option I need to set to say don't turn on the screen saver until 5 minutes of inactivity? Or is this a bug?

share|improve this question
    
Is there an option I need to set to say don't turn on the screen saver until 5 minutes of inactivity? It doesn't solve your problem, but I always though that was the default, i.e. when you type or move the mouse, the screensaver timeout gets reset and only starts counting down again when the machine is left idle –  binarybob Mar 6 '12 at 21:44
    
That's how every screen saver I've used in the last 15 years has worked - agreed. Surely this is a bug in 10.7.3? –  Matthew Lund Mar 6 '12 at 21:51
    
I have the same issue. The screen saver engages at different times, even while typing. I've turned off hot corners, changed screen saver, with no effect. This started a few months ago. –  user28770 Sep 8 '12 at 14:25
add comment

2 Answers 2

According to Apple Support:

If you use a screen saver, it starts automatically after your computer is inactive for a time. You can also choose a shortcut so your screen saver starts when you move the pointer to a corner of the screen.

  1. Choose Apple menu > System Preferences, click Desktop & Screen Saver, and then click Screen Saver.
  2. Open the Screen Saver pane of Desktop & Screen Saver preferences

  3. Click Hot Corners. Choose Start Screen Saver or Disable Screen Saver from the pop-up menu for a corner you want to use; and then click OK. To use the Command (), Control (^), Option (), or Shift () key together with a hot corner, press the key while the pop-up menu is open. For example, if you press the Shift key, the Start Screen Saver command changes to ⇧-Start Screen Saver.

To deactivate the screen saver and return to the desktop, press any key or move the mouse.

Additional screensaver configuration options for Lion are listed in this Apple Support KB.

This issue could definitely be a bug, but you could also check your screensaver configuration to determine whether you've turned on hot corners - it's possible that your mouse pointer may have triggered the screensaver. You can also choose to disable screensavers completely to avoid this issue.

share|improve this answer
    
Yep, I had checked that. None of the hot corners are defined to do anything. –  Matthew Lund Mar 6 '12 at 22:14
add comment

I am having the same issue so can confirm it is a bug. I've disabled my hot corners just to make sure I'm not accidentally hitting them. I had my screensaver set to 30 mins, and it seems to happen every 30 mins. So it seems that the computer thinks I'm away, even though I'm using it. This is reproducable by dragging the slider from 30 mins to 5 mins, the screensaver comes on automatically before I even release the mouse (from sliding the setting from 30 mins to 5 mins)

This is one strange bug.

share|improve this answer
add comment

protected by Community Sep 20 '12 at 19:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.