Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I got a quite nice pair of in-ear headphones which block noise very well (with a very tight seal, not noise cancellation). Before that, I used Apple earbuds.

With these better headphones, I'm now often hearing a hissing noise. This happens constantly while a sound is being played (music, alerts, etc.) and for several seconds after. I assume this was happening with my previous headphones but there wasn't a good enough seal for me to hear it.

This doesn't happen with my iPod or iPad. How can I stop it from happening?

share|improve this question
possible duplicate of How can I make my Macbook Pro's headphone jack stop "humming"? – timothymh Mar 6 '12 at 21:15
I don't think this is a duplicate question. While it's difficult to tell without testing, in general I would equate "hums" with grounding problems while your issue is most likely something else—see my answer. A hiss is not a hum is not a pop/crackle. – jaberg Mar 6 '12 at 21:53
up vote 7 down vote accepted

Tough to know for certain, but my money is on an impedance mismatch between the output of the Macbook and your new headset. Or, perhaps more accurately stated, excessively sensitive (low impedance) headphones are revealing flaws in the MacBook audio output circuit.

Care to share the model of headphones you're now using? My guess is it's a low-impedance model intended for use with portable audio devices. You can boost the impedance by adding an in-line volume control adaptor like the Shure EA650. You will find other suggestions for solving this problem, including some DIY answers, by searching the forums at

For more information/background see: Impedance, and how it affects audio equipment by Rod Elliot and Sound On Sound: Understanding Impedance.

Another possible solution: I have M-Audio powered monitors plugged into my MacBook Pro, and plug my Etymotic earplugs into the headphone jack on the monitors for private listening. I haven't noticed any noise problems with this set-up.

share|improve this answer
I'm using the MEElectronics M9-BK (quite cheap, but quite good). Is there any kind of software method of increasing impedance? As far as I can tell, it would need to be hardware, but I wouldn't mind being pleasantly surprised. ;) – timothymh Mar 6 '12 at 22:10
Solve electrical problems electrically and acoustic problems acoustically — Bob Heil. An obtuse of saying this is not something you fix with software. – jaberg Mar 6 '12 at 22:23
Okay, so now I've learned that impedance is not directly rated to cost. ;) The specs I found rate the impedance of your M9-BK's at 16Ω. By comparison my Etymotic E6's are rated at 48Ω but their E6i, designed specifically for "iPods" is also rated at 16Ω—the lower impedance helps eek a little more oomph out of the low-powered amplifiers in portable electronics—not a bad thing if that's the device you're driving them with. Bottom line, try increasing the impedance, or use different "cans" with your Macbook. – jaberg Mar 6 '12 at 22:35
I wouldn't assume that it will fix your problem, but it will fix it for some people experiencing hiss through low impedance headsets so I think you're safe in accepting it. – jaberg Mar 6 '12 at 22:52
This has solved my problem. Thanks! – timothymh Nov 26 '12 at 15:57

I have had the same hissing with my MacBook Pro and a pair of Sennheiser CX300-II in-ear headphones. I solved this by changing the output format of the Built-in Output device from 48kHz/2ch-16bit to 48kHz/2ch-32bit.

This can be done as following:

  • Open Audio MIDI Setup. Use Spotlight to find it or find the application in your Utilities folder
  • Make sure your headphones are plugged in
  • Click on `Built-in Output'
  • On the right it will say Source: Headphones and format will be 48000.0 Hz / 2ch-16bit
  • Click on 2ch-16bit and choose 2ch-32bit from the drop down menu

I choose 2ch-32bit, but I've noticed that any other value than 2ch-16bit already eliminates the noise.

I am still in the process of figuring out why this works, anyone with more understanding of this issue, please feel free to edit my answer accordingly.

share|improve this answer
I have the same experience as @LauriRanta, though I hope it's not a 24-speakered set of headphones! – timothymh Jun 24 '12 at 23:11
ok, weird. That means I had a different problem... – Saaru Lindestøkke Jun 25 '12 at 5:40
zero noise. pure magic. – Abrackadabra Nov 22 '15 at 11:27
My hero! Problem occurred after updating to el capitan – Oritm Feb 9 at 15:17

I had the same buzz noise as questioned. Though, it went away when i unplugged my MacBook from the adapter. The buzz appeared every time i used a specific power socket. Changing the power socket made the noise go away.

share|improve this answer
I suggest you or an electrician take a look at how that particular socket is wired. It may be ungrounded or mis-wired. – IconDaemon Nov 26 '12 at 13:59

Thanks to Bart Arondson for tips to solving my own issue. I've posted details in case they're helpful to someone else.

I'm using a Heil PR40 Mic (Dynamic microphone) with a Mackie VLZ4 mixer, and was disappointed that (after spending a lot on equipment) I had an unacceptable hiss on my audio, regardless of output (headphones, speakers, etc.)

Following Bart's lead to the Audio MIDI Setup I changed the Input from the mixing board. I changed the Format to 24000 Hz, with 1ch-16bit Integer.

Frequencies below 24000 sounded hollow/aquarium-like, and frequencies above created the hiss/ringing that had been driving me crazy. Also, using the 2ch-16bit and the 1ch-8bit settings were unacceptable. Apologies if I mucked the link to the screenshot!

![screenshot of Audio MIDI settings]

share|improve this answer

Unplug from power outlet, "problem solved". Noise stopped, although this is a main issue from the power connector from the mac.

Good luck to you all.


share|improve this answer
I don't get the downvotes. This worked for me! – Andrew Latham Oct 9 '14 at 19:27
Unfortunately it solves the issue, but it's hard to live without power :( – Pivasyk Jun 28 '15 at 15:05

I actualy heard the hiss when music isn’t on using earphones. i have beats pro heaphones. i found that when i disconnect power mag safe from macbook the hiss disapears completely. i guess it is electrical interference. also hear interference when i switch off heater when magsafe is connected. :D

share|improve this answer

Hope this helps some of you, what solved my issue was the following,

  • Open Terminal
  • type cd /Library/Preferences/Audio and press Enter type
  • ls and press Enter you should see two files, and
  • type sudo rm and press Enter it will prompt you for your password
  • type sudo rm and press Enter this will delete the audio settings for your OS
  • type sudo killall coreaudiod and press Enter that will restart the audio system and all should be working now, at least, it did for me.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.