Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have just updated to 4.2, and the space for my music is still taken according to iTunes, and the device "About" screen says I have 723 songs, but I cannot see it in the iPod app. I assume that another sync is required to activate the content again or something to that effect?

EDIT:

iTunes can see the content on my phone and even allow me to play it. I will attach some images to illustrate the issue. My photo library was updated and seems to work. I have also tried closing all apps, which did not help.

alt text

share|improve this question
    
I had the same problem as did lots of people based on some quick Google searches this morning. Sounds like a tester at apple will be out of a job today. –  JohnFx Nov 23 '10 at 13:38

5 Answers 5

up vote 0 down vote accepted

To add to your own answer, you will have to re-sync with your library or reset some contents (via the correct iTunes).

share|improve this answer

I am speculating, that this is what happened: I did the update on another computer (not the one my music is synced to), which invalidated the copy protection of my music library, so when I plugged my phone back into the machine where my music library is stored it did the deed for me. That is what seems to have happened anyway.

share|improve this answer

While Martin's answer is correct to bring back the songs, but here the songs are not lost/ disappeared from iPhone. There is a way to fix this.

After upgrading to 4.2.1, the songs are still there, but by somehow the songs are not shown in iPod.app. All I did is plug-in the headphones and click the middle button to play the songs. And it did worked.

No need to re-sync the songs.

share|improve this answer

found the answer with the second suggestion here.

share|improve this answer

Re-start touch (Hold home and off/on buttons) and sync again with iTunes, bingo!

share|improve this answer
    
tried that . .didn't help . .still says "No content" –  leora Dec 25 '10 at 0:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.