Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In my MacBook Pro running Lion, I use Command + Tab to switch apps, and Alt1 + Tab for switching windows within an app.

In my work iMac, also running Lion, Alt + Tab isn't doing anything, and I can't find any setting for that. Also, I dont remember tweaking anything in the MacBook Pro to get this to work.

note 1 - Alt is the same as Option on most Mac keyboards, but mine just has Alt printed.

share|improve this question
Just for the record Command + ` (the key above tab) works really well for me. –  bassplayer7 Mar 6 '12 at 13:18
This is not default behaviour on your MBP. Somebody must've changed the default key mapping. –  EmmEff Mar 6 '12 at 23:37

4 Answers 4

up vote 15 down vote accepted

Option+Tab shouldn't be assigned to switching windows by default. You could've reassigned it in the Keyboard preferences:

It could also be handled by some third party app like Witch, LiteSwitch X, or Keyboard Maestro on the MacBook Pro.

share|improve this answer
Thanks! I dont remember having done that, but whatever. I reccomend this shortcut, its very convenient to have command + tab and alt + tab so close to one another –  0al0 Mar 6 '12 at 11:35

Try Command + ~ (tilde). That is the default.

share|improve this answer

Mavericks use Command + Tab to switch between the application but if you want to cycle through the different window of same application use this: Command + Tab + DownArrow it will show all the open windows of the same application which you can select using arrow keys.

share|improve this answer

On german Keyboard Layouts changing windows of an app is mapped to Command + < and Command + Shift + < respectively.

share|improve this answer
I have a german MBP15 Retina with english keyboard. CMD-~ didn't work, but CMD-shift-< does. CMD-> does other things, though. Thank you. –  lilalinux Feb 2 at 16:15
Ah, of course I had to add shift: < is a shift character :-) –  lilalinux Feb 2 at 16:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.