Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I create or update a calendar event on one device, it is not being propagated to my other devices via iCloud despite having iCloud enabled for calendars on all my devices and the Apple ID being the same everywhere.

share|improve this question
3  
Check that the calendar(s) showing are not only "on my Mac" but include iCloud's calendars. –  Richard Mar 5 '12 at 16:32
    
Both sets of calendars are visible. –  Pottypuss Mar 22 '12 at 10:30
    
Any answers for this ongoing issue? I have had the same issue pop up over and over, seems the only way to fix is to delete and re add. which is a huge pain in the bumm, cause my phone will not sync with anything, including a backup. it is like it doesnt talk, but it will listen. anything i put on my cal goes no where, but anything added to icloud or my computer magically shows up on my phone. –  user53339 Jul 15 '13 at 22:42

6 Answers 6

Problem: Synching a shared calendar did not work from my Mac to iPhone (using iCloud), but worked from iPhone to Mac.

What I did: In the Calendars App on the Mac I exported the calendar - to have it as a backup. The old calendar could not be deleted on the Mac, it just re-appeared again (confirming that changes made on the Mac did not sync to iCloud). I therefore deleted the old calendar on my iPhone and it disappeared on the Mac as well. Good.

Then I re-imported the exported (old) calendar and gave it a new name. It now works. Probably would work using the old name as well (since internally the app uses calendar-IDs).

share|improve this answer

Your iOS device may be saving new calendar events to a local calendar instead of the iCloud calendar. This is particularly confusing if that local calendar has the same name as the calendar you want to use in iCloud. To change the default calendar for saving events on an iOS device, navigate to Settings > Mail, Contacts, Calendars > Default Calendar and select your preferred calendar under your iCloud account:

enter image description here

share|improve this answer
    
Syncing problems come in two flavors: easily resolved sweet and oh, my aching head sour. Unfortunately, you've seemingly bitten into a lemon here. Update your question with as many details and steps that you've already taken and we'll keep plugging away at it. Best of luck finding a sugary center. –  jaberg Mar 22 '12 at 10:39
    
Thanks jaberg, I have checked this and it seemed that all the events in question were correctly placed in the iCloud calendars. I may consider changing the default calendar as you suggest, however, I have the added complication that I am running Snow Leopard and do add events there occasionally. Since SL "doesn't do iCloud", I may stick with assigning the calendar manually to ensure the events also sync over when I plug in my devices (even if this means duplicate entries sometimes). I wish Apple would allow iCloud for iCal .... :-( –  Pottypuss Mar 22 '12 at 10:46

This Might be a Problem with an Entire Shared Calendar

If the appointment that is not syncing is in a shared iCloud calendar, it is possible that syncing no longer works for that entire calendar. I experienced this while I was traveling in late September 2012 -- the missing appointments were my itinerary which was in a calendar I share with my executive assistant.

Sidebar: My suspicion is that Apple somehow broke the syncing of (some or all) shared calendars created prior to the iCloud update for the iOS6 release.

Confirm Problem

You can confirm that syncing is broken for a shared calendar by doing the following:

  1. log into your iCloud calendar using a non-mobile browser
  2. find the appointment that is not syncing
  3. change the appointment from a shared calendar to a non-shared calendar

If the appointment shows up on your iOS device when you change it to a non-shared calendar, then that entire shared calendar might not be syncing to iOS devices anymore. Test some other appointments in the shared calendar to confirm that the entire calendar is affected.

Another symptom of a broken shared calendar is that it causes Outlook Sync (installed by iCloud Control Panel on Windows) to hang (i.e. endlessly "Refreshing..." in the Outlook Toolbar).

"Solution"

The only solution that seems to work in this situation is to create an entirely new shared calendar. The new shared calendar should accept new appointments and sync them to all devices, but it won't have the appointments from your old broken shared calendar. The appointments from that calendar will have to be migrated to the new calendar.

Appointment Migration Option #1 - Use Outlook Sync

If you are the sharee (but not the sharer) of the broken calendar it is possible that you will see all of the appointments in Outlook (but not in iOS). In this case, it might be possible to change the calendar view in Outlook to a list view and drag-and-drop the appointments en masse from the broken calendar to the new, working shared calendar.

Appointment Migration Option #2 - Use iCloud Web Page or iOS calendar

You can migrate appointments from the broken calendar to the new, working shared calendar by logging into the iCloud Web Page and manually changing each appointment's calendar. This is very time consuming if you have many appointments.

Solution to Outlook Sync Hanging

The only way to solve the Outlook Sync hanging problem that is caused by a broken shared calendar is to delete the broken calendar. Make sure that you migrate all of the important appointments before you do this, because deleting the calendar will also delete all of the appointments on it.

share|improve this answer

I had this problem and turned out that a setting had been put in place to only sync calendars 1 month back (Go to Settings. Mail, Contacts, Calendars. Sync. All Events)

So I could not see my data from prior months even though it was there in iCloud. I changed it to Sync All Events, turned phone off then on, and voila.

share|improve this answer

I've had this problem ever since I got ICloud, months ago. I finally decided to sit at my computer all day until I figured it out and I finally found the answer!

It's just a setting in Outlook-- a hard to find setting! I've given the link below, but also pasted the instructions here. Need to re-start and wait a few minutes for the changes to take place, but it worked for me! On this same page are also instructions for other apps and devices.

http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

Outlook 1.On the Tools menu, click Trust Center, and then click Add-ins. 2.View the add-ins and application extensions that are categorized as follows: ◦Active Application Add-ins Lists the extensions that are registered and currently running in your Office program. ◦Inactive Application Add-ins Lists the add-ins that are present on your computer but are not currently loaded. For example, smart tags or XML Schemas are active only when the document that references them is open. Another example is the COM add-ins that are listed in the COM Add-ins dialog box. If the check box for a COM add-in is selected, the add-in is active. If the check box for a COM add-in is cleared, the add-in is inactive. To learn how to open the COM Add-in dialog box, see the section called Turn off or manage the installed add-ins. ◦Document Related Add-ins Lists template files that are referenced by currently open documents. ◦Disabled Application Add-ins Lists add-ins that were automatically disabled because they are causing Office programs to crash.

If you find "ICloud Outlook ADd-in" is listed in "Disabled Add-Ins", click to highlight it, and then find "MANAGE: COM Add-ins" below and click "Go".

You will then see a list of all "Add-ins". Make sure ICloud Outlook Add-in is checked. You should now see it moved from "Disabled" to "Inactive". Restart your computer and it should become active. It will take a few minutes to sync once you restart and open Outlook.

share|improve this answer

I also have problems getting IOS6 "Appointments" calendar to sync with iCloud (my MacBook iCal and Windows8 Pro Outlook 2010 were working normally). I have 4 calendars on iCloud: Appointments (default), Calendar, Work and Home. It took me a while to realise that only the "Appointments" calendar was failing to Sync. I created a new "Appointments2 calendar which appears to work normally". I was planning to migrate my "Appointments" to "Appointments2" using Outlook (because its easy) ... BUT its very comforting to realise that I'm not alone and someone else came up with this already!

share|improve this answer
    
hmmm ... well this workaround worked for me for while .. but now I'm back to square 1 :( –  Pete Morton Nov 22 '12 at 17:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.