Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am not sure how this happened, but many of my services are now in, what I believe is spanish:

Screenshot of my Keyboard system prefs

How do I change this back to English? My language in the Language & Text system pref is set to English where ever possible. I am using Mac OS X 10.6.8.

share|improve this question
    
Viewed over 1000 times and not a single up vote. Le sad... –  emiller Apr 17 '13 at 20:58
add comment

1 Answer

up vote 1 down vote accepted

This problem seems to crop up occasionally, and I haven't heard a definitive solution outside of the standard troubleshooting routines: determine if the problem is a software setting by creating a new user account, rebuild permissions, and so on.

Beyond the basics, there are two solutions that might help. First, in this thread over at the Apple discussion forums, someone has a similar problem and is able to resolve it by removing some spurious login items, then logging out and logging back in. It's worth looking at your login items suspiciously.

Second, you might try to change the system language to something new, like French. Log out and back in, then change back to English. It may be that you have some wonky settings left over from an old program, and that switching away from English and back re-aligns everything.

share|improve this answer
    
Wow. I am relieved to know other people have this problem, too. I guess I should say... ¿¡¡porque?!! –  emiller Mar 5 '12 at 15:52
    
Also, I'm pretty strict on what login items I use. I've got nothing on that I don't need. I guess it's onto plan B changing to French and back again... –  emiller Mar 5 '12 at 15:54
    
Bingo. Changing to french and back again did it. For all those interested, the language was changed in the Language & Text System pref. I dragged French to be the first language in the list of languages I prefer. Logged out/in again. Switched back to English. Logged out/in again. And all was well. –  emiller Mar 5 '12 at 15:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.