Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Mac OS X 10.5.8. I am not able to extract .tar or .tgz files with any of the extractor utilities (Mac OS Default Archiver or WinZip or 7zip or any other, I have tried almost all possible).

Each of them give same error:

"Unable to unarchive. (Error 32 - Broken pipe.)"

There is no problem with archived files, I can extract each of them when I use same extractors on Windows.

Would someone please help me with this?

share|improve this question

migrated from Mar 4 '12 at 10:07

This question came from our site for professional and enthusiast programmers.

Does it work from a terminal for tgz files? Open a terminal and cd to the folder that has the files and try something like this:

tar xvzf file.tar.gz

Or for plain tar files:

tar xvf file.tar
share|improve this answer
I usually face the same problem and go back to terminal to extract the archives. I get this even with zipped files. – ismail Mar 4 '12 at 10:19

There may be too many NUL blocks at the end of the tar file, so that the tar command prematurely finishes its executions (and closes its standard input) after having received two NUL blocks while the gunzip command is still trying to write to the pipe that now has no reader anymore (which raises an EPIPEerror message with error number 32 for a broken pipe; for more information see: Tar-filled pipes).

According to the output of newproc.d Archive seems to use the following commands (Mac OS X uses bsdtar by default):

/usr/bin/gunzip -c file.tar.gz | /usr/bin/tar xf - -C dir

To see the number of trailing NUL blocks in the tar file use:

gnutar -tzf file.tar.gz -i --block-number | nl | tail -n 25

To extract the tar archive try:

# -i: ignore blocks of zeros in archive (normally mean EOF)
gnutar -i -xvf file.tar.gz

.zip files can be tested with:

unzip -lv
unzip -t
share|improve this answer

check the directory and the path, the scipt may lead you to users/download/folders/blah

but you keep it on users/favourite/folder/blah (example) thats make the error.

share|improve this answer
Could you clarify that a bit? – Alex Jul 10 '13 at 8:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.