Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I was using Tuxera NTFS for a while on my external drives but then my trial ran out.

So then I installed ntfs-3g from macports.

When I connect my external drive, OSX automatically mounts it, but it is read-only.

But if I unmount the drive, and use ntfs-3g to mount the drive in a terminal, then I can get normal read/write access to it.

The problem is that Finder doesn't list it in the list of drives that it sees.

How can I get Finder to recognize the drive?

How can I get OSX to use the ntfs-3g program that allows read/write access instead of whatever it normally uses when connecting an external NTFS drive?

If I let OSX automatically mount the drive and type mount, this is what I get for the external drive.

/dev/disk2s1 on /Volumes/Expansion Drive (ntfs, local, nodev, nosuid, read-only, noowners)

The problem is the part that says "read-only." How can I remove that?

share|improve this question
    
Q: "The problem is that Finder doesn't list it in the list of drives that it sees". Is this only true for the "Finder Sidebar" and/or for the "/" dir ?! –  v2r Mar 3 '12 at 2:46
    
It doesn't list it under "Devices" where hard drives are normally shown. I can still find it in finder if I go to the directory where it's mounted. –  z-buffer Mar 3 '12 at 4:23
    
Ok! Open a window and browse to "/Volumes", where the HD Drives are visible and drag them into the Finder Sidebar under Devices. This works usually! –  v2r Mar 3 '12 at 4:34
    
I tried dragging them over, but they won't go there. They can't even be put in Favorites. –  z-buffer Mar 3 '12 at 5:30
    
Now that makes sense. As you said before, you only have "write access". I suppose you need to change permissions permanently for the HDD in question, to make it work as it was before. I never used "Tuxera NTFS" or "ntfs-3g", so i don't know for sure if there is a conflict and if so, can i be easily resolves via the preferences settings etc.. I am sure, that here is your solution tuxera.com/forum/… –  v2r Mar 3 '12 at 6:11
show 1 more comment

2 Answers

up vote 1 down vote accepted

I finally got it working. I used the info at this site. The instructions are now included in brew installations.

Basically use brew or macports to install ntfs-3g, fuse4x, and fuse4x-kext. If you have an icon in System Preferences for fuse or macfuse, remove those, you don't need them. Follow the instructions after you finish installing them. You can also use brew info to see those instructions if you missed them before.

When I did brew info ntfs-3g I found this.

To replace the default Mac OSX automounter:
    sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.orig
    sudo ln -s /usr/local/Cellar/ntfs-3g/2012.1.15/sbin/mount_ntfs /sbin/mount_ntfs

I also did brew fuse4x-kext and found this.

  sudo cp -rfX /usr/local/Cellar/fuse4x-kext/0.9.0/Library/Extensions/fuse4x.kext /Library/Extensions
  sudo chmod +s /Library/Extensions/fuse4x.kext/Support/load_fuse4x

After running those commands I got the ntfs drives to automount and be visible in Finder with read/write access.

share|improve this answer
add comment

Can you please copy/past the following command in Terminal.app and post your output? (Before you do, please hook up your external HDD, don´t mount it in Terminal and also replace /Volumes/MyHDD with your "dir")

id
ls -l /Volumes
ls -l /Volumes/MyHDD
echo ---------------

In case your external HDD uses a space in its name please enclose the argument, like so:
ls -l "/Volumes/My HDD"

In Terminal.app you'll get something like this:

localhost:~ v2r$ id  
uid=501(v2r) gid=20(staff) groups=20(staff),402(com.apple.sharepoint.group.1),204(_developer),100(_lpoperator),98(_lpadmin),81(_appserveradm),80(admin),79(_appserverusr),61(localaccounts),12(everyone),502(access_bpf)  
localhost:~ v2r$ ls -l /Volumes  
**total 8**  
drwxrwxr-t@ 35 root  admin  1258 Feb 15  2011 OS X externalHDD  
lrwxr-xr-x   1 root  admin     1 Mar  3 03:53 OS X 10.6 -> /  
localhost:~ v2r$ ls -l /Volumes/externalHDD  
ls: /Volumes/externalHDD: No such file or directory
localhost:~ v2r$ echo ---------------

As you can see, my permission for the externalHDD is set to drwxrwxr-t@ 35 root admin for 1258 Feb 15 2011 OS X externalHDD which means that i have full permission +rwx

Without permission you'll get something like this along the lines: d---r-xr-x-t and ls: externalHDD: Permission denied

You also need to apply one of the following characters "u" to symbolize the file’s owner, "g" for its group, "o" for other (everyone else) for the mode-change clause: o-x.
Now, when you say that you already tried sudo chmod +rwx you missed out on the mode-change clause!!

Depending on your current permission settings, (which i am still not certain of) you can use a command, similar to this sudo chmod -R u+rwX /Volumes/MyHDD but make sure that it is the right one, or you could make it even worse! Refer to the image below, your command-line output and the possible command you yet need to customize, in order to fix permissions for the right group (being u supposingly!)

enter image description here

If nothing works, then backup your data and reformat the HDD to restore default settings. Worst option, but effective.

share|improve this answer
    
I edited my question to show information that is more relevant. –  z-buffer Mar 3 '12 at 11:42
    
I already tried sudo chmod +rwx, but it doesn't work. OSX cannot normally write to ntfs drives. If I use ntfs-3g then I can write, but then the drive doesn't show up in Finder's device list. –  z-buffer Mar 3 '12 at 17:00
    
you maybe want to read the edited post once again! –  v2r Mar 4 '12 at 12:15
    
You said you don't use ntfs-3g. What do you use? –  z-buffer Mar 4 '12 at 12:46
    
No extension so far, only what comes with the native OS –  v2r Mar 4 '12 at 12:49
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.