Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How do I stop iMessages from appearing automatically on my home screen? Does anyone have any ideas?

share|improve this question
add comment

1 Answer 1

Settings -> Notifications -> Messages. Set Alert Style to None.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.