Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use Internet Sharing at work to create a local WiFi network (sharing the GigE connection) for my various iOS and tablet devices to connect through. After the 10.7.3 update, I cannot turn sharing off after I unplug the Ethernet cable. All the checkboxes in the system pref pane are cleared, but I am unable to join a WiFi network.

After I plug the Ethernet back in, I can then disable sharing, but only while it's plugged in.

As best I can guess, there might be some xinetd cruft laying around, but I haven't the slightest clue as to how to look for it or fix it. Any ideas?

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

I found a relatively simple solution not involving a system restart - just bring the WiFi interface down and then back up:

$ sudo ifconfig en0 down
$ sudo ifconfig en0 up

In my case en0 is the AirPort interface of my MacBook Air.

Note that turning the AirPort off and on again doesn't work, but bringing the interface down does the job.

share|improve this answer
1  
Awesome, thanks! One way to find which interface to use: Apple menu -> About This Mac, then click the "More Info..." button, then the "System Report..." button, and finally click WiFi in the list on the left. The right pane will display a bunch of info about your WiFi configuration, including the interface. –  Nate Cook Jul 30 '12 at 21:50
    
Worked great. Also, thanks @Nate Cook for the note about using More Info to find the actual wifi interface, mine turned out to be en1. –  Brian Wigginton Sep 12 '12 at 17:18
    
The solution described here (brining the the WiFi interface down, then up again) saved me from going insane over restarting my MacBook Pro every time to restore WiFi functionality after Internet sharing. Really appreciate this, guys! –  user56350 Sep 3 '13 at 11:06
add comment

I've had this problem regularly. The only way I can find to fix it is to turn off internet sharing, then reboot. It seems to hang once you've shared the Ethernet connection.

share|improve this answer
add comment

I have the issue intermittently, and so far the only simple way I have found to fix it is to plug into a wired connection, then turn sharing off. This usually fixes it. What is strange is that I have the problem often enough that I am now regularly checking to ensure that I have disabled sharing prior to leaving work, but I still have problems when waking the system from sleep after arriving at home. Something is getting stuck; even when sharing has been disabled, it often acts as if it is still active. I'm wondering if sharing needs to be disabled for a certain amount of time before the setting is cleared internally?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.