Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Recently the tap to click on my trackpad will disable itself after a restart and I have to go into System Preferences to enable it. Has anyone experienced this and know of a solution?

I'm running Snow Leopard on a white MacBook (Mid 2010).

share|improve this question
    
It probably won't help, but you could try deleting ~/Library/Preferences/com.apple.driver.AppleBluetoothMultitouch.trackpad.plist‌​. Missing preference files are recreated automatically, so that should be harmless. –  Lauri Ranta Feb 29 '12 at 1:22
add comment

2 Answers

Open Terminal.app and enter the following to (re-)enable tap to click on the Trackpad:

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -bool true

Then, log out and log back in again.

share|improve this answer
add comment

That is a common issue for some 10.5 and 10.6 users with different MB/MBP models, sadly!

I once had a very similar problem, regarding my trackpad and fixed it, by patching the Trackpad.prefPane which is located here: /System/Library/PreferencePanes/Trackpad.prefPane with an older one from a previous update. You can extract the one from within the .pkg repository of your Installation DvD, if your trackpad worked fine after the first system installation and before the first system update. (If you do so, please backup the Trackpad.prefPane currently used by your system)!!

Another method would be to alter the current setting of the current Trackpad.nib used. You need to inject the Trackpad.nib, since it is compiled in order to make it editable and then tick the box (+ save your alteration) you now make, when using System Preferences GUI for the temporary fix. Again, backup your files before you give it a go!

If you don't know what i am talking about i suggest you don't try, since you can break your system which the would require a reverse-engeneering of my suggested solution(s) or a fresh install!!

Apple is aware of this and other issues, though they won't admit it easily, so in due time there will be a fix within one of the system-updates.

Good luck and if you succeed let me know please!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.