Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2010 Macbook Pro (running Snow Leopard) and I connect to my home internet thru Wifi (via Thompson router).
The problem is, after I choose my Wifi from a list of Wifis and enter the password, majority of the times it fails to connect saying "Incorrect password", even though its correct. All I have to do is keep pressing the return key until a connection is established.
Very few times I get connected automatically without a need to enter the password and sometimes I get the connection on the first attempt, but usually it takes around 5-10 tries.
It doesn't happen to my Windows (vaio) laptop though. Anyone seen something likely and got it fixed?

share|improve this question
Do you need to enter a password everytime you use Wi-fi? Definitely doesn't match the experience I've had with my 2009 MBP. Additional info that might be helpful - what's your OS version (Lion, Snow Leopard, etc.). – JW8 Feb 29 '12 at 0:01
You could try 'Forget this network' in the Airport settings through System Preferences -> Network, then reconnect fresh again – Nathan Dries Feb 29 '12 at 0:05
@JW01: Not really. A few times I connect without entering the password. Updated the question with this info. – Alexander Feb 29 '12 at 2:48
@NathanDries: Your suggestion works. Could you post your comment as answer? – Alexander Mar 6 '12 at 22:15

You could try 'Forget this network' in the Airport settings through System Preferences -> Network, then reconnect fresh again

share|improve this answer
It worked well for a week or so but the problem returned back. Will I have to keep forgetting my network again and again? – Alexander Mar 11 '12 at 22:41
Hmm, very strange... Is the network that you are having issues with the highest in your list of preferred networks? – Nathan Dries Mar 15 '12 at 22:36
There are no other networks but this in preferred network list. If there is no other better solution, your one will solve my problem for sometime at least. – Alexander Mar 23 '12 at 18:53
up vote 1 down vote accepted

The problem was solved by a firmware update. It specifically addressed this password issue.

share|improve this answer
Firmware issue on what? Your router? – gotnull Sep 11 '14 at 3:19
No. Macbook Pro. – Alexander Sep 12 '14 at 11:47

For others finding this thread because they too have the problem:

On my wife's MacBook Pro, the answer turned out to be that the laptop could not differentiate between the 2.4GHz and 5GHz version of the wireless, and if it connected to a different one than last time, told her the password was wrong. The cure was to 'split' the two wi-fi networks by adding '-5' to the 5GHz version SSID, then the Mac could tell them apart. It has the same passcode for both networks (although they could be different) and is now happy to connect to either, every time.

Why this suddenly crops up for some, is down to relative signal strength on each frequency, and maybe a new router having the 5GHz band for the first time, but with the same SSID. (That is how they are normally set up, but Apple has problems with that).

HTH someone.

share|improve this answer
I had a similar problem: other devices were able to connect to wi-fi, but my MBP would show "Invalid password" – using the exact same password. I figured out that a custom password was only set for the 2.4 GHz band, but the 5 GHz band still had the original default password (which was printed on a label on the FiOS-G1100 router). I fixed the router configuration by applying the same custom password to both the 2.4 GHz and 5 GHz bands. – hftf Jul 5 at 5:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.