Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After a recent upgrade of iTerm2 (I'm on build 1.0.0.20120203), when I open up iTerm2, it restores all of the terminal windows I had open. How do I disable this behavior so it doesn't "remember" how many windows I had open?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

This is the resume feature introduced with Lion.

defaults write com.googlecode.iterm2 NSQuitAlwaysKeepsWindows -bool false
share|improve this answer
1  
Or (assuming it's Lion, and not an iTerm feature), remember to hold down the Alt/Option key whenever you Quit, which will work in any application. –  scottishwildcat Feb 27 '12 at 14:51
    
@scottishwildcat Yeah, thanks for pointing that out. It doesn't work with any application though. E.g. Chrome's setting in it's preferences overrides the shortcut. –  gentmatt Feb 27 '12 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.