Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an USB drive with four partitions. SuperDuper uses these partitions to back up my mac. Since SuperDuper is scheduled, I have the USB drive constantly connected. But quite frankly the noise of the USB drive is driving me nuts. So I eject the partitions every time I boot the mac up. SuperDuper is configured so that it mounts the partition when it is scheduled to back up and unmounts it again.

I am trying to find a way so that I do not have to manually eject the partitions. I have two methods that work. I edited the /etc/fstab file with the UUIDs and prevent the partitions from mounting and I tried the method of making a logon script that calls a "do shell script "diskutil unmount....."". Both methods work. The partitions do not get mounted. BUT the drive motor does not "turn off". I have to go into Disk Utility and eject the unmounted (light-gray) drive again for the USB drives motor to be quiet. It doesn't really matter which one of the four drives I choose to eject again, ejecting one does the trick.

I also noticed that if I automatically eject three of the drives on boot and then manually eject the fourth one that the USB drive powers down. So there seems to be a difference between ejecting via script and right-mouse click "eject".

Does anyone know why this is? Is there a way to eject the partitions so that the USB drive understands this?


share|improve this question
You are aware that there is also diskutil eject …, right? – Harald Hanche-Olsen Feb 27 '12 at 12:28
That did the trick! Thanks! – Joseph Feb 27 '12 at 13:23
I wonder whether diskutil unmountDisk device would also have the required effect in this case – unmounting all volumes without ejecting … – Graham Perrin Jul 16 '14 at 19:29
up vote 1 down vote accepted

As Harald suggested the solution is to use "diskutil eject" not unmount.

For anyone else looking at this thread, my login script looks like this:

delay 5
   do shell script "diskutil eject \"/Volumes/MYPARTITION\""
end try

Thanks again!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.